PlatformIO Community

Problem with Platformio on Raspberry Pi 1 Model B

All “pio account” commands (login/show etc) runs for a while but then returns with no output and just gives me the command prompt again.

The “pio remote agent” also does the same.

I use RASPBIAN STRETCH on my Raspberry Pi 1 Model B.

I use the Super-Quick installation script to load Platform IO Core on my pi which worked fine.

The first time I run a “pio account” command pioplus is installed fine but then the command does not give any output, error or feedback. Just gives me the prompt again after a few seconds.

I have tried RASPBIAN STRETCH Lite too. There was one error when pioplus was installed and I had to “apt-get install libpython2.7” and it was resolved. But it does the same in that it only gives the command prompt again with no output or feedback.

Any help or suggestions would be appreciated. I want to use the Pi as a remote agent for field deployment and testing.

Could you try apt-get install python-dev?

Similar issue PIO remote step by step for dummies?

Thanks for the info and link, it does seem to be related (same distro, same issue)

apt-get install python-dev did not install anything, all was already at latest version.

Additional info:

root@raspberrypi:~# lsb_release -a
No LSB modules are available.
Distributor ID: Raspbian
Description: Raspbian GNU/Linux 9.4 (stretch)
Release: 9.4
Codename: stretch

Think the root of the problem lies here:

root@raspberrypi:~# ~/.platformio/packages/tool-pioplus/pioplus
Illegal instruction

I have just tried the same on DietPi distro with the exact same results. Installation goes through fine, the pioplus command gives “Illegal instruction”. I presume something in the binary does not seem to be compatible or a mismatch with libraries…

Sorry, that was our issue. We rebuilt PIO Plus Core with a support for ARMv6l. Please run pio update. Everything should work now.

Thank you Ivan, everything is working perfect now.

Just very glad we could get it resolved.

Thanks for the support and great work you guys are doing on PlatformIO!

1 Like