Problem with IDE operation

Code has been created to work with the mpu6050 in the platformIO environment. The code was compiled and flashed into esp32 dev. The program works. All this was done on a computer 3 months ago. Now it was necessary to make changes to the code. The code stopped compiling and does not generate any errors (computer running windows 11. All updates are installed). The same code compiles, loads and works on another computer (windows 10). What is the problem ? How to fix ?

What does the crash log show?
Is the same ESP32 being used?
What is the content of platformio.ini ?

Why is the MPU6050 library not listed in the Dependency Graph? It should look something like this (depending on the MPU6050 library used)

Dependency Graph
|-- MPU6050 @ 1.3.0
|-- Wire @ 2.0.0

Is the same version of the Arduino Espressif Platform installed on both PCs?

Crash log is not shown, there is supposedly no error.
I am using the same esp32 as before.
Attached below is the content of platformio.ini


yes, the version of Arduino Espressif Platform installed is the same.

Make sure that the same platform version is used on both PCs:

platform = espressif32@6.5.0
board = esp32dev
framework = arduino
upload_port = COM4
upload_speed = 115200
monitor_port = COM4
monitor_speed = 115200

Which MPU6050 library do you use and how is it installed? I don’t see any lib_deps in your platformio.ini which defines the library.

Your picture shows an old platform version espressif32@6.1.0 (Arduino 2.0.7).
The current platform version is 6.5.0 (Arduino 2.0.14)

I tried to update to version 6.5.0. it didn’t help, the error remains, after build the program doesn’t compile.

But the compilation finished without errors?! So it did compile.

That’s the problem. Despite the fact that it says that everything was successful, the code is not actually compiled. When I run the same code on the second computer, the compilation notification line appears.

It compiles and the firmware.elf was build correctly.

Make sure you have selected the correct project and environment.

Okay, I’m pretty sure I got it right. What else could be the problem? I thought I had a compilation problem, but apparently not. The mpu6050 just stopped initializing on my computer. There is no problem in the library, because the same code works correctly on the second computer.

If there is an error when compiling or linking, error messages are displayed.
But there are no error messages there.

I think there is a linguistic problem here. When you say “computer”, do you mean the ESP32 or the machine on which you create the code with VS-Code / PlatformIO, compile it and upload it to the ESP32?

How do you check this? Does your program print any serial output?