Problem including cstdint after running platformio platform update

Earlier today I was prompted with a message in the terminal saying that some of my platforms need updating (specifically atmelavr and nxplpc).
So I ran platformio platform update as prompted, and now my code is breaking.

The code I’m compiling is for the lpc11u68 board on the nxplpc platform.
I’ve discovered that the problem is that __cplusplus is less than 201103L, which implies that the -std=c++11 flag isn’t being passed to the compiler, but I’ve got the flag included in my build_flags in my platformio.ini:

; PlatformIO Project Configuration File
;   Build options: build flags, source filter
;   Upload options: custom upload port, speed and extra flags
;   Library options: dependencies, extra library storages
;   Advanced options: extra scripting
; Please visit documentation for the other options and examples

platform = nxplpc
board = lpc11u68
framework = mbed
build_flags =
extra_scripts =

I tried to downgrade by running platformio platform update nxplpc@3.3.0 but I got a ‘platform not recognised’ error.

If I put the following in my main.cpp:

#if defined(__cplusplus)
	#warning "You're on C++ at least"
	#if __cplusplus > 201103L
		#warning "C++11?"
		#warning "No C++11... :C"

I get the following in the terminal:

src\main.cpp:2:3: warning: #warning "You're on C++ at least" [-Wcpp]
#warning "You're on C++ at least"
src\main.cpp:6:4: warning: #warning "No C++11... :C" [-Wcpp]
#warning "No C++11... :C"

So evidently my platformio.ini is either being ignored or there’s something not right with the env settings.

I’ve found a temporary workaround to this problem by placing:

 "cxx": [

in ~/.platformio/packages/framework-mbed/platformio/variants/LPC11U68/LPC11U68.json.

It solves the problem for now but doesn’t explain what the source of the problem is or if it’ll happen the next time I update as well.
Also I’m sure there must be a better fix than this.