platfromIO not working

Hello, Im trying to use platfromIO in VSCode but it doesnt work. When I write a code and then I upload it it acually says the upload was succesful. The arduino LEDs blinks. However thats all, the program doesnt do anything. Do you have any idea? I had this problem in the past too but restart of PC helped. Thx for every reply

Well I uploaded older version of PlatformIO and now it works

That’s weird, we would be interested in seeing why that occurs.

  • What exact platformio.ini do you have?
  • What code are using?
  • What behaviour are you expecting from the code?
  • What did you downgrade to get it working? (VSCode PIO extension, PIO core, platform, …?)

Today I uploaded again to newest version and still same problem. One thing that I found is there is something new in the bottom commands. I try to upload the photo whats there – Upload, after I change this to env:uno(Arduino) (which wasnt present in the older version)!! PLatformScreenshot , it works (with newest version)! I’d like to know where can I find my platformio.ini in the VSCode. Code Im using is working in Arduino IDE. Behaviour from code is nothing ( if we are talking about problems with SUCCESS upload howver literally nothing happens - but ARduinos LEDs blinks, blinks same as when some code is uploaded. It just doesnt do anything then). And I downgraded platfromIO IDE to 2.2.1. However as I said now is working 2.3.0 when I changed to env:uno(Arduino)

Indeed, the project and environment selector is something new.

It is a file like any other in your project. If you click on the first icon in the VSCode sidebar, you get the file explorer.

Make double sure that you select the right project and environment as you see in the file explorer and platformio.ini of the project.

If it still not works, post the full code and platformio.ini as text, along with the settings in the Arduino IDE with which it works.