PlatformIO Windows Source Control Network Drive

I have a raided server on which I host my files. I reinstalled Windows and ofc PlatformIO, I’ve been having issues for weeks now.

I cant click “Initialize Repository” nothing happens. If I do this on a folder on my PC it works fine. I’ve even tried 0777 permissions, running Visual Studio Code as Admin. Nothing seems to work.

I’ve tried to create the folder locally and then just copy it to the server, but that hack doesn’t work either.

Any ideas on why this happens all of the sudden? It worked fine before I reinstalled Windows.

In a terminal, can you use git init in the folder you want to initialize the repo in manually? Or does that fail too?

A new Git client (Git - Downloads) was installed too right?

1 Like

Yea I’ve tried that. The .git folder with all the content gets created. But PIO Source Control doesn’t detect it for some reason.

I’ve manually made sure the permissions are 0777 on that folder.

It’s not PlatformIO at this point, it’s VSCode’s git system. When you disable the Github extension, does it happen too?

1 Like

Not sure if I can do that? I mean, I need the git extension in order to initialize a repository right? Or am I missing something.