PlatformIO Toolbar and Home icon not showing in VSCode

I’ve been using pio with vscode on my mac for something like a year now, but tonight all of a sudden, the pio toolbar and the home icon disappeared from the bottom of my vscode window.

I’m using Core 4.2.2a3 and Home 3.1.1 on Visual Studio Code 1.42.1.

I tried typing “pio update” into the vscode terminal, and a bunch of stuff got updated, no errors, but alas, still no home icon.

When I type “pio home” into the mac terminal, it opens up dandy in my browser, but still not in vscode.

I also tried uninstalling and reinstalling the platformio extension in vscode, but still no home icon.

Anyone have any suggestions?

Is there any output in the developer console in VSCode? (“Help” -> “Toggle Developer tools”)

1 Like

Oh you’re the best, maxgerhardt!

The console spit out the problem immediately - apparently there was a problem with the cpptools extension (C/C++ for Visual Studio Code), on which pio depends. I uninstalled and reinstalled cpptools (had to remove platformio ide in the process), and now everything works! Thanks so much!


I had the same issue but in Windows 10.

Followed your steps and It’s now solved. (y)


Perhaps it is a very simple thing but it took me some time figure it out. In Win10, with VScode, using the rigth button of the mouse over the toolbar you can control the icons that appear on it. In my case, PlatformIO was unchecked (I do not know why?). I selected it again and it worked again.

Best regards,


no platformio on rigth button of the mouse over the toolbar

It literally says in the bottom right corner that it’s still installing stuff.

1 Like

using the rigth button of the mouse over the toolbar you can control the icons that appear on it

This is a nice hint (and not dependent on the OS), thanks.
Here is my solution for the same problem:

In Settings/Extension/PlatformIO there is an option called
“Activate Only On Platform IOProject”
This was turned off for me, and PIO Home icon was not shown at startup.

1 Like

In my case, it was a “trust” issue. In my Extension list, next to the PlatformIO, there was a Shield Icon/symbol. Clicking on it, brought up a screen with two boxed labeled “Trusted” / “Untrusted”. I excepted/selected the trusted option and PlatformIO installed. Required a restart of VScode. Then the PlatformIO icon was in the toolbar on the left.

Same path > “Settings/Extension/PlatformIO”, but, I had to check/enable the setting:
“Platformio-ide: Activate Project On Text Editor Change”