I’m trying to compile a project that requires the library platformio/Streaming@0.0.0-alpha+sha.5. However, the package cannot be located.
I tried both, PlatformIO running on Windows10 64 BIt and Linux Debian12 64 Bit.

Any help is appreciated.

There are no results in the registry for a library platformio/Streaming.
Do you have further informations about the library?

Where did you get the information that you need such a library?
Please provide more detailed information about your project and show the content of your platformio.ini.

This is the project that I tried to compile: GitHub - yeckel/D-StarBeacon

And this is, how the platformio.ini looks like:

data_dir = src/data

platform = espressif32
#board = ttgo-lora32-v21
framework = arduino
lib_deps =
ESP Async WebServer
thingpulse/ESP8266 and ESP32 OLED driver for SSD1306 displays@^4.2.0
monitor_speed = 115200
upload_speed = 921600
upload_port = /dev/ttyUSB1
monitor_port = /dev/ttyUSB1
monitor_filters = esp32_exception_decoder
board_build.partitions = no_ota.csv

The Stream class is part of the Arduino Core.
Remove the lib-dep and change #include <Streaming.h> to #include <Stream.h>

I can’t test this, because I am not on my computer right now, but I think this should work.

Thanks, Sivar. I tried it and the issue is gone. However, now I’m running into issues in parts of the source code which included both, the Streaming.h and the Stream.h. I’m already in touch with the author of the project and he will take a look at it.

1 Like