Platformio produces no output with ESP32 and "Hello World" project

platformio.ini is
platform = espressif32
board = esp32dev
framework = arduino

Am unable to make any projects to work. My projects were working, then I switched to an ESP8266 which did not work, then switched back to an ESP32 and could not get any projects to work.

Any thoughts?

Vestal, NY

What is the code?

What is the output of a upload procedure?

How do you start the serial monitor?

Have you made sure to select the right project and environment using the "environment selection switcher?

Not enough info given :confused:

Here is the program:

#include <Arduino.h>
void setup() {
  // put your setup code here, to run once:

void loop() {
  // put your main code here, to run repeatedly:

Output from build:

> Executing task in folder test: C:\Users\georg\.platformio\penv\Scripts\platformio.exe run --target upload <

Processing mhetesp32devkit (platform: espressif32; board: mhetesp32devkit; framework: arduino)
------------------------------------------------------------------------------------------------------------------------------------------------------------------------Verbose mode can be enabled via `-v, --verbose` option
PLATFORM: Espressif 32 (3.0.0) > MH ET LIVE ESP32DevKIT
HARDWARE: ESP32 240MHz, 320KB RAM, 4MB Flash
DEBUG: Current (esp-prog) External (esp-prog, iot-bus-jtag, jlink, minimodule, olimex-arm-usb-ocd, olimex-arm-usb-ocd-h, olimex-arm-usb-tiny-h, olimex-jtag-tiny, tumpa)PACKAGES:
 - framework-arduinoespressif32 3.10004.210126 (1.0.4)
 - tool-esptoolpy 1.30000.201119 (3.0.0)
 - tool-mkspiffs 2.230.0 (2.30)
 - toolchain-xtensa32 2.50200.80 (5.2.0)
LDF: Library Dependency Finder ->
LDF Modes: Finder ~ chain, Compatibility ~ soft
Found 26 compatible libraries
Scanning dependencies...
No dependencies
Building in release mode
Retrieving maximum program size .pio\build\mhetesp32devkit\firmware.elf
Checking size .pio\build\mhetesp32devkit\firmware.elf
Advanced Memory Usage is available via "PlatformIO Home > Project Inspect"
RAM:   [          ]   4.5% (used 14700 bytes from 327680 bytes)
Flash: [==        ]  16.0% (used 209799 bytes from 1310720 bytes)
Configuring upload protocol...
AVAILABLE: esp-prog, espota, esptool, iot-bus-jtag, jlink, minimodule, olimex-arm-usb-ocd, olimex-arm-usb-ocd-h, olimex-arm-usb-tiny-h, olimex-jtag-tiny, tumpa
CURRENT: upload_protocol = esptool
Looking for upload port...
Auto-detected: COM3
Uploading .pio\build\mhetesp32devkit\firmware.bin v3.0
Serial port COM3
Chip is ESP32-D0WDQ6 (revision 1)
Features: WiFi, BT, Dual Core, 240MHz, VRef calibration in efuse, Coding Scheme None
Crystal is 40MHz
MAC: a4:cf:12:0a:6c:54
Uploading stub...
Running stub...
Stub running...
Changing baud rate to 460800
Configuring flash size...
Auto-detected Flash size: 4MB
Compressed 15872 bytes to 10319...
Writing at 0x00001000... (100 %)
Wrote 15872 bytes (10319 compressed) at 0x00001000 in 0.2 seconds (effective 519.7 kbit/s)...
Hash of data verified.
Compressed 3072 bytes to 128...
Writing at 0x00008000... (100 %)
Wrote 3072 bytes (128 compressed) at 0x00008000 in 0.0 seconds (effective 1794.9 kbit/s)...
Hash of data verified.
Compressed 8192 bytes to 47...
Writing at 0x0000e000... (100 %)
Wrote 8192 bytes (47 compressed) at 0x0000e000 in 0.0 seconds (effective 2901.8 kbit/s)...
Hash of data verified.
Compressed 209920 bytes to 105370...
Writing at 0x00010000... (14 %)
Writing at 0x00014000... (28 %)
Writing at 0x00018000... (42 %)
Writing at 0x0001c000... (57 %)
Writing at 0x00020000... (71 %)
Writing at 0x00024000... (85 %)
Writing at 0x00028000... (100 %)
Wrote 209920 bytes (105370 compressed) at 0x00010000 in 2.5 seconds (effective 675.2 kbit/s)...
Hash of data verified.

Hard resetting via RTS pin...

Output is selected via clicking on the symbol of the “plug”

I have tried several different “esp32” environments; but, no luck. All my programs for the esp32 were working Saturday. They were not working on Sunday.

What other information do you need?

Vestal, NY

And the project which you want to upload and that the above code resides in is called “test”? Regarding

It was all working Saturday, then stopped working on Sunday.

I am going to uninstall everything then reinstall it all back again.

If worse comes to worse, will install it on a different computer.

Thanks for your help.

Vestal, NY

Before you do that can you show a screenshot of VSCode?

Just press Alt+PrintScreen while VSCode is the active window, then Ctrl+V it into a new post.

Also you kinda didn’t answer my question? Creating a new project and not switching to it via the linked methoded might be the culprit.

I did attempt to reload PIO…now, when I try to compile and run any other project, I get the very first one…test

I loaded PIO under “Atom” and it works perfectly.

So, the problem now is that no matter what I try to compile and run, it compiles and runs the first sketch.

Regarding your question, I didn’t understand it.

I run a project by clicking on the project in the window that shows all projects, the clicking on the source code. compiling and running it. Perhaps this is the wrong way to select a project to change, compile and run. How should I be selecting a project?



Exactly that’s the issue.

PLEASE please, I’m trying to point you to the documentation since 3 posts, read it once: PlatformIO IDE for VSCode — PlatformIO latest documentation

Have you made sure to select the right project and environment using the "environment selection switcher?

Its all working…thanks for your help! Your “Arrow pointing to default” made it work!..

Duh!..not enough coffee here in my office!

I much appreciate your patience for a “newbee” to Platformio!


Yes, I have finally read the documentation! Again, I much, much appreciate your patience for a newbee who didn’t follow your instructions and didn’t read the documentation! I apologize for the incovenience and will try to do better in the future!

Many Thanks