PlatformIO - PIO Home


#1

Hi all,

I’m somewhat of a total n00b on this, sorry. This is new territory for me so please be gentle :slight_smile:

I was looking to use an alternative for the Arduino IDE and came across PlatformIO, interesting.
I tried Atom, it keeps hanging on "PlatformIO IDE: Installing… Atom dependencies - I gave up…
Now I tried Visual Studio Code following the steps here: PlatformIO IDE for VSCode

I got to the point were it says: Click on “PlatformIO Home” button.

(I can only post on image for now as a new user)

But it looks like this:

That’s a bad thing right ?

Would you be so kind to let me know what is wrong here and how to fix it ?

Thanks !


#2

Could you open Left Side Bar > PlatformIO > Quick Access > New Terminal and type

pio home

Does it work in browser now?


#3

Nope, my browsers (firefox/chrome/seamonkey/PaleMoon/internet exploder) only show:


#4

Right Click > Inspect > Developer Console > Messages

Do you see any errors? Please share here.


#5

I’m sorry Ivan, I just don’t know where to:
Right Click > Inspect > Developer Console > Messages


#6

Using Google Chrome -> Right Click on PIO Home Page -> Inspect > Console.