PlatformIO Community

PlatformIO not picking up library update

Hi, I have updated my github library a few times since february, trying different version number schemes etc, but I can’t get the update to take.

My library is: jamessmartcell/AugustESP32: August Lock Bluetooth interface for… (platformio.org)

And the gibhub is: JamesSmartCell/AugustESP32: ESP32 bluetooth implementation for August smart lock. Available on PlatformIO (github.com)

What I have tried:

  • first update from 0.9 to 0.91 in Febrary. No update to library in PlatformIO for a few weeks.
  • try update from 0.91 to 1.0, wait for 5 days, no update.
  • try update from 1.0 to 1.0.1 and exactly duplicate the latest example library.json, wait 5 days no update.

Can the auto-discovery bot be prodded again? It appears to be a common issue but maybe it was solved a while back. I can’t find anything wrong in my library.json but there could be something I overlooked. I have another library on PlatformIO and it updates correctly.

But you have no tags for the new release: Releases · JamesSmartCell/AugustESP32 · GitHub

Is that’s what’s missing CC @ivankravets?

You published the package manually using pio pkg publish — PlatformIO v6.0 documentation

You need to use this command every time you have a new release.

1 Like

Thanks for checking I’ll do that.

Good point, I will add those; but I don’t think that’s what’s causing the library not to update. I also have another library on platformio that updates correctly when I update the library.json.

If you publish a library using pio pkg publish, it removes it from the “auto-update” list (legacy)

Thankyou, it works perfectly and instantly :slight_smile: