PlatformIO Community

Platformio netbeans

program does not compile in netbeans

[env:nucleo_f411re]
platform = ststm32
board = nucleo_f411re
framework = mbed

cd ‘/home/asus/Documents/PlatformIO/netbeans’
/home/asus/.local/bin/platformio -f -c netbeans run
failed to start /home/asus/.local/bin/platformio: No such file or directory

That’s not what the error says. It says ‘you tried to run the program /home/asus/.local/bin/platformio but I can’t, because that file isn’t there!’ Are you sure that’s the right path? Is there a platformio in /home/asus/.local/bin?

yes, Code block and Sublime text work…

That’s a good start. So, to be clear,

Is there a platformio in /home/asus/.local/bin ?

1 Like

Hm… can you double check if it’s marked as ‘executable’… it’ll be on one of the other tabs, along with permissions, etc.

Ok, that box is ticked…

What happens when you do a

cd /home/asus/.local/bin

… followed by …

./platformio

from the Netbeans terminal? Does it run then? As you should get at least a different error message from the looks of things…

Netbeans terminal:

sh-5.0$ cd /home/asus/.local/bin
sh-5.0$ ./platformio
sh: ./platformio: /usr/bin/python: неверный интерпретатор: Нет такого файла или каталога
sh-5.0$

Is this a problem with netbeans or with platformio?

Can you execute platformio in a normal terminal?

yes, pio commands are executed

Does your Netbean IDE modify PATH variables in any way? Especially regarding the Python interpreter? I’ve had the problem with Eclipse that it “failed to launch process platformio” but it had old modified Python paths in the project configuration.

1 Like

I do not know. I’m just starting to work with netbeans. How can I check this?

Could there be a problem in the platformio configuration file for netbeans?
After all, SublimeText and CodeBlock work…

The platformio.ini is so basic that it cannot be wrong. If anything if it works on two other IDEs it indicates all is good

This suggests that special characters in the path may be to blame, but I don’t see any…

This hints at possible environment changes. What does that settings page look like?

Also what’s your NetBeans version and OS version?

I mean the project settings file that creates platformio for netbeans (platformio project init --ide netbeans --board ).


Try echo $PATH in both your terminal where platformio works, and the netbeans terminal. See if anything changes.

Which install method did you use to install the PlatformIO CLI?

Also, try which platformio from the working terminal, to see what is being run… on my linux box it’s /usr/bin/platformio because I used the quick install script.

Edit: I’ve just tried PIO and Netbeans 8.2 on my Manjaro install… and an abridged version of my Run -> Build Project log is included below if it helps / to show what it looks like when it works! :confused:

My path is the same inside or outside the Netbeans terminal.

/home/pfeerick/.local/bin:/usr/local/sbin:/usr/local/bin:/usr/bin:/opt/cxoffice/bin:/var/lib/flatpak/exports/bin:/usr/lib/jvm/default/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl

Netbeans version info
Product Version: NetBeans IDE 8.2 (Build 201609270201)
Updates: Updates available to version NetBeans 8.2 Patch 2
Java: 1.8.0_101; Java HotSpot(TM) 64-Bit Server VM 25.101-b13
Runtime: Java(TM) SE Runtime Environment 1.8.0_101-b13
System: Linux version 5.4.17-1-MANJARO running on amd64; UTF-8; en_AU (nb)
User directory: /home/pfeerick/.netbeans/8.2
Cache directory: /home/pfeerick/.cache/netbeans/8.2
Build output
cd '/home/pfeerick/Projects/netbeans_test'
/usr/bin/platformio -f -c netbeans run
Processing nucleo_f411re (platform: ststm32; board: nucleo_f411re; framework: mbed)
--------------------------------------------------------------------------------
Verbose mode can be enabled via `-v, --verbose` option
CONFIGURATION: https://docs.platformio.org/page/boards/ststm32/nucleo_f411re.html
PLATFORM: ST STM32 6.0.0 > ST Nucleo F411RE
HARDWARE: STM32F411RET6 100MHz, 128KB RAM, 512KB Flash
DEBUG: Current (stlink) On-board (stlink) External (blackmagic, jlink)
PACKAGES: 
 - framework-mbed 5.51401.200110 (5.14.1) 
 - toolchain-gccarmnoneeabi 1.70201.0 (7.2.1)
Collecting mbed sources...
...
Compiling .pio/build/nucleo_f411re/src/main.o
Generating LD script .pio/build/nucleo_f411re/STM32F411XE.ld.link_script.ld
Linking .pio/build/nucleo_f411re/firmware.elf
Checking size .pio/build/nucleo_f411re/firmware.elf
Building .pio/build/nucleo_f411re/firmware.bin
Advanced Memory Usage is available via "PlatformIO Home > Project Inspect"
RAM:   [          ]   2.6% (used 3464 bytes from 131072 bytes)
Flash: [=         ]   8.2% (used 43068 bytes from 524288 bytes)
========================= [SUCCESS] Took 32.61 seconds =========================

BUILD SUCCESSFUL (total time: 33s)
1 Like

Terminal linux:

asus@asus-X550CL:~$ echo $PATH
/home/asus/.local/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games

Terminal netbeans:

sh-5.0$ echo $PATH
/app/bin:/usr/bin

Check the rest of my post above… I added more to it, so you may not have seen it if you only saw a email notification. Specifically, how did you instlal the PlatformIO CLI, and what does which platformio return when run on both terminals?

Regardless, it looks like something is very wrong with the netbeans terminal path, as it’s dropping a lot of stuff, but I can’t see any settings or such that would control/affect that, so hopefully someone familiar with NetBeans knows what could be causing that.