'platformio' is not recognized as an internal or external command


I’m trying to build a project and this is the output.

‘platformio’ is not recognized as an internal or external command,
operable program or batch file.
Unable to execute: platformio
Make sure cmd:‘platformio’ and cwd:‘C:\Users\Project_PlatformIO\fProject’ exists and have correct access permissions.
Binaries are found in these folders: C:\Python34…

Yesterday, i can build the project correctly, but after make the PlatformIO upgrade, I can`t do anything.

I try to include the path “C:\Users.atom\packages\platformio-ide\penv\Scripts” in PATH, but with no results.

I’m a win8.1 user.

Hi @Dr.C !
Which version of python is installed in your system? I see you have Python 3.4 in your path. Currently, PlatformIO only supports Python 2.x versions. Have you tried to reinstall platformio-ide plugin?

Hi @valeros!

I have installed both of them, Python 2.7 and Python 3.4. And yes, I tried to reinstall platformio-ide plugin.

Is it possible for you to delete Atom home directory c:\Users\user\.atom?
BTW, what is output python --version command from cmd?

Yes, i can delete Atom directory. The output from python --version is “Python 3.4.3”

The output from python --version is “Python 3.4.3”

Probably, it’s our problem. Could your please temporarily delete path to Python 3.4.3 from your %PATH% environment variable and try to reinstall PlatformIO IDE plugin?

I modified the path to Python3.4 and reinstalled PlatformIO. Everything is working!

So, if i restore the path to Python3.4, i have the same issue.

Why with old version of PlatformIO this didn’t happened?

I just installed platformio for the first time, on Windows 10, and I’m getting the same message when I build, but only after updating.

If I build “Blink” right after installing, no errors. However the little squirrel on the bottom-right is blue, and mouseover says

An update will be installed the next time Atom is relaunched.

If I then relaunch Atom, the blue squirrel is gone, but when I try to build I get:

‘platformio’ is not recognized as an internal or external command,
operable program or batch file.
Unable to execute: platformio

@occamman please close IDE and remove `c:\Users%USER%.atom folder and start IDE again. It should reinstall PlatformIO IDE.

I have the same issue. I also tried a complete reinstall but I still have the same error message. It does work if I open a terminal inside atom and call platformio. But the menu build and clean commands do not work.

Please use PlatformIO IDE which has built-in PIO Core.

If you need PlatformIO Core CLI globally, see Redirecting...

No, I still have the same issue.

Strange I had a reboot in the meantime and it started working. I doubt that this did anything but now also with “Path” as system variable I no longer get the errors.

Do you use patched file from?

Yep, I replace the standard file with that one.

Could you try now to restore stable version https://raw.githubusercontent.com/platformio/platformio-atom-ide/0301e31eeace684ef7fc224e8abd5c3f3a5e5829/lib/maintenance.js

Please restart and retest. Thanks.

Ok, I removed platformio, re-installed it and everything works fine now.
Thanks for the quick fix.

That did the trick for me, too,

I am still having this issue.
I have Windows 10 & Python 2.7.10.
I have turned off McAffee realtime scan to reload platformio
I deleted the .atom directory
platformio reinstalled without any errors
If I run the “>_” command I can use pio or platformio
If I try to compile I get "‘platformio’ is not recognized as an internal or external command, operable program or batch file."
I have tried the above mentioned maintenance.js trick, but the problem persists.

What can I do net?

Thanks for your help.

Update: If I open the “>_” command line and enter “platformio run” then it builds. So the issue seems to be happening with the toolbar shorcuts.

Please uninstall PlatformIO IDE with Atom:

Now, install PlatformIO IDE Redirecting...

1 Like