PlatformIO is not installing in macOs Catalina?

Dear community I am new to PIO, I decide to code arduino bords on PIO but i just download atom and install plug in of PIO but its fail the message is the it require python 2.7 but in macOs by default 2.7.9 python have but then i tryed to install python 2.7 from website but the python 2.7 is not installing in macOs catalina and showing the message " The Installer could not install the software because there was no software found to install."
bellow are screenshot :

Atom plug in installing problem screeshot:
Screen Shot 2020-03-17 at 9.37.00 PM

So if you open a terminal and execute python or python2, what output does it give you with what version?

You should also be able to execute which python to get the folder in which it is installed. Then you can maybe press the “I have Python 2.7” button and point it to the right folder / file.

We work on a new portable and standalone PIO Core installer. See GitHub - platformio/platformio-core-installer: PlatformIO Core Installer

Could you open system terminal type this command without sudo?

python -c "$(curl -fsSL"

nothing happedn i tried

yes there is default python that comes with macOs python 2.7.9 bellow is the screenshot the problem is macOs Catalina dont support the 2.7.0 vesion Screen Shot 2020-03-17 at 9.37.42 PM

this is when i tried to install python 2.7.0 Screen Shot 2020-03-17 at 9.36.07 PM

also that the python by macOs is installed there is no path for it to find it

So what exactly does which python (or where python) output?

2.7.9 but there is no location of it

which is a command for the terminal which retrieves the path of the program on the right. There must be a location for it, the interpreter binary is somewhere in the system. What does which python output in the terminal?

this is the screentshot Screen Shot 2020-03-17 at 9.37.42 PM

You executed

python --version

and not the requested

which python

as said

E.g. on a unix system this outputs


Same should work on Mac. Using this path you can, as I said,

obtained by that command.

Could you try this standalone installer GitHub - platformio/platformio-core-installer: PlatformIO Core Installer?

Thank you , but i now tried and and manually select the path of 2.7 python but still the message shows python 2.7 not found

Please provide a full output from

python --verbose

See instruction how to get script GitHub - platformio/platformio-core-installer: PlatformIO Core Installer