PlatformIO ignoring request to build littlefs image

Trying to switch to littlefs, Cut and pasted the “board_build.filesystem = littlefs” line to platform.ini file but it seems to be ignored. System stilll tries to create the default spiffs.bin file. Here’s the platform.ini file

platform = espressif32
board = esp32doit-devkit-v1
board_build.filesystem = littlefs
framework = arduino

monitor_speed = 115200
debug_tool = esp-prog
debug_init_break = tbreak setup
lib_deps = 
    ESP Async WebServer
    arduino-libraries/Arduino_JSON @ 0.1.0

upload_port = com3

and the build output for the filesystem image

> Executing task: C:\Users\royan\.platformio\penv\Scripts\platformio.exe run --target buildfs --environment esp32doit-devkit-v1 <

Processing esp32doit-devkit-v1 (platform: espressif32; board: esp32doit-devkit-v1; framework: arduino)
Verbose mode can be enabled via `-v, --verbose` option
PLATFORM: Espressif 32 (3.2.0) > DOIT ESP32 DEVKIT V1
HARDWARE: ESP32 240MHz, 320KB RAM, 4MB Flash
DEBUG: Current (esp-prog) External (esp-prog, iot-bus-jtag, jlink, minimodule, olimex-arm-usb-ocd, olimex-arm-usb-ocd-h, olimex-arm-usb-tiny-h, olimex-jtag-tiny, tumpa)
 - framework-arduinoespressif32 3.10006.210326 (1.0.6)
 - tool-esptoolpy 1.30000.201119 (3.0.0)
 - tool-mkspiffs 2.230.0 (2.30)
 - toolchain-xtensa32 2.50200.97 (5.2.0)
LDF: Library Dependency Finder ->
LDF Modes: Finder ~ chain, Compatibility ~ soft
Found 33 compatible libraries
Scanning dependencies...
Dependency Graph
|-- <FastLED> 3.4.0
|   |-- <SPI> 1.0  
|-- <ESP Async WebServer> 1.2.3
|   |-- <AsyncTCP> 1.1.1
|   |-- <FS> 1.0
|   |-- <WiFi> 1.0
|-- <Arduino_JSON> 0.1.0
|-- <LittleFS_esp32> 1.0.5
|   |-- <FS> 1.0
|-- <WiFi> 1.0
|-- <FS> 1.0
Building in release mode
Building SPIFFS image from 'data' directory to .pio\build\esp32doit-devkit-v1\spiffs.bin

As noted above it’s building spiffs.bin, in fact has a later error because it doesn’t like the included subfolder.

Puzzled as no one else seems to have the issue? This is on a new clean Windows install in the last month so should be uptodate.

This option only exists for ESP8266, not for ESP32. See docs and compare here.

You need to follow the library author’s instructions here at GitHub - lorol/LITTLEFS: LittleFS library for arduino-esp32.

LittleFS is still not integrated in the Arduino-ESP32 core, hence no support out of the box. See Embed littleFS · Issue #3765 · espressif/arduino-esp32 · GitHub and Embed littleFS · Issue #3765 · espressif/arduino-esp32 · GitHub.

Thanks for the quick reply, although that’s certainly not an answer I was expecting.

I had noticed the 8266 references in the documentation but generally assume 8266=32 unless noted otherwise. Doubt I’m the only one. But I stand corrected, and will defer to the Arduino IDE for the moment.