Platformio-ide-terminal installation hangs

Hello, I’m relatively new to Atom. I posted this on the Atom forum but no one has an answer and they suggested that I post the issue here as well. Seems it’s a pretty weird issue.

I have Atom installed on a Windows 10 machine. It seems to work great. But I’m trying to install platformio-ide-terminal. I do not have platformio-ide installed. I just want the terminal for now.

I start the install from the inside Atom Settings Install Packages. Then it just hangs. No errors, no event log entries, nothing obvious at all. It’s been sitting at this for two days:

Here’s what I’ve tried:

  • Reboot and try again.

  • Uninstalled Atom, including deleting the .atom folder, and try to reinstall everything. Several times.

  • Tried using the CLI, apm, installer. Same results, it just hangs.

  • Installed and ran Atom with admin rights, just in case, still hangs.

Here’s what I see happening in the back-end:

  • I can see where starting the install downloads a number of items, presumably dependencies, and the platformio-ide-terminal package. They are downlaoded to the .atom.apm folder.

  • After the download it seems to just hang up. None of the packages ever make it ot the .atom/packages folder. And the terminal package never shows as having been installed in the Atom Just hangs at the point shown in the image above.

  • it seems that it’s unable to unpack/unzip and move the packages to the packages folder.

Help… :slight_smile: