PlatformIO IDE not activating, missing CPPtools

Been using VSCode/PlatformIO for awhile now to compile Marlin for 3D printing.
After an upgrade to MacOS Catalina PlatformIO will not activate.
Toggle Developers Tool gives me an error that it cannot find ms-vscode.cpptools and because of that cannot activate PlatformIO.
I have tried uninstalling/reinstalling PlatformIO and C/C++ but with no luck.
I cannot say for sure that the MacOS upgrade has anything to do with the failure… it can be that I have messed something up myself in VSCode… I am a novice user.
Please help.
I attach a screenshot of my TDT.

Not sure why it isn’t starting… but it seems to be suggesting files are missing. Check your extensions in VSCode, and see if the C/C++ extension is enabled/present. If it is, you might want try removing it (you’ll probably have to remove the PlatformIO extension first, due to the dependency) and re-installing it and the PlatformIO extension. Maybe something got deleted or moved with the upgrade.


Thanks for your reply.
I have already done the un-installing and re-installing of both c/c++ and PlatformIO.
But I still get the same errors.

1 Like

Drats! You may also want to open an issue over at the cpptools github then, and see what the devs over there say - as I don’t see any issues that seem to cover this particular error. :frowning:

1 Like