PlatformIO IDE install failure under Atom editior under windows

Help, I am trying to install PlatformIO-IDE under Atom editor. When I install it never completes the Atom Dependencies as indicated by the blinking down-load icon. The initial configuration and the intelligent code completion get checked but the “Atom Dependencies” and “PlatformIO Core” do not. It appears to be stuck in some-kind of loop.

In my debugging I have tried the following:

  1. killing and restarting atom. (this time the “PlatformIO Core” gets checked immediately but the “Atom Dependencies” still is flashing.
  2. I installed LLVM (Clang)
  3. I uninstalled atom several times.
  4. I uninstalled atom I deleted the directories under the root user account folder: C:\Users<myusername>.atom .config and .platformio directories.
  5. I tried running atom as admin before the install.
  6. I took pycharm off my path.

My path: PATH=C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0;C:\WINDOWS\System32\OpenSSH;C:\Program Files\LLVM\bin;C:\Users\ptm72\AppData\Local\Microsoft\WindowsApps;C:\Users\ptm72\AppData\Local\atom\bin

Thanks for the help!

Already tracked in Platformio-ide · Issue #2457 · platformio/platformio-atom-ide · GitHub.

As a general note, Atom support is not the main development focus; it’s VSCode. Consider looking at that.

Solved per Platformio-ide · Issue #2457 · platformio/platformio-atom-ide · GitHub.