PlatformIO IDE for VScode

Yeah, this cool. Also debugging works. :grinning:
Can you add the features from the PlatformIO Extension, like SerialMonitor, one click upload etc. (see screenshot)

I don’t know why, but linting works not as standard, only with PlatformIO Extension it works. :confused:

Thanks a lot for the feedback! :slight_smile: Would be thankful for positive review here PlatformIO IDE - Visual Studio Marketplace

Yes, we will create similar Toolbar which we have in PIO IDE for Atom

Could you explain in details? Do you use PIO Core 3.0.0b8? Is yes, open commands pallete (Cmd+Shift+P) and search for “PlatformIO: Rebuild Index”. Close/Open VSCode.

Does it work?

The linting is very crazy. I have two MacBooks, on the main one, linting works,
on the other older one I make a fresh install, but linting doesn’t work.
All files, settings etc. are the same and I doesn’t remember what I’ve done that
it works on my main macbook but not on my older one.:sob:

After deleting the hidden .vscode folder and reinstallation of IDE and extensions it works now.:grinning:

I’ve just made some improvements to PIO Core VSCode genertor. Now, it should work very well on Windows/Mac.

Also, toolbar is added. Will be announced in the next version.

I download the new version and have some problems. On my main laptop the install was no problem. On my old MacBookPro13’’ (Sierra 10.12.5) I get following error:

I tried to install and reinstall app and extensions but nothing helps.

I meet with the same issue (with Windows 10)

Do you still have this issue with AttributeError?

Always have, but not AttributeError