PlatformIO Community

PlatformIO IDE for VSCode 2.0 Beta – Help us with testing!

If you need some help, feel free to ask!

1 Like

I’ll help too, as long as Ivan doesn’t ask me to write any Urkranian docs! And with breaking… er, testing the universal library… :rofl: :rofl:

btw, a behaviour change if possible… I noticed in the other topic about file system upload to the ESP8266 that it’s now under the environment specific ‘Platform’ tasks… which unfortunately doesn’t show under ‘Generic’ (now General) branch even if there is only one environment in the project. Is it possible to change that behaviour so it does show under the general branch in that instance? Otherwise you have to dig into the environment block even when there is only one environment.

1 Like

Hi @ivankravets.

While digging into PIO’s guts, I found that my terminal wouldn’t recognize pio. I opened my .zshrc file and found this:

#compdef pio
_pio() {
  eval $(env COMMANDLINE="${words[1,$CURRENT]}" _PIO_COMPLETE=complete-zsh  pio)
}
if [[ "$(basename -- ${(%):-%x})" != "_pio" ]]; then
  compdef _pio pio
fi 

So far, so good. Out of curiosity, I ran _pio command and got this:
Screenshot 2020-06-17 at 12.12.19

I’m not good enough at shell to dig further, but I will definitely try :sweat_smile:

1 Like

Did you run the platformio system completion install command to get that? (which I only of know because I remember mention of the auto completion from the release notes for 4.3.4)

No, because the piece of code I found in my .zshrc was likely written there by beta installer. I keep an eye on my .zshrc file and often tweak it, so I know this code is definitely not mine :grin:

From what I guess this piece of code sets up code completion for zsh, in order to run, for example, platformio system completion install from anywhere :grin:.

You need to add PIO Core to your shell as well. https://docs.platformio.org/en/latest/core/installation.html#install-shell-commands

1 Like

Dang it… I was going to say that also! I just installed zsh and ran though this… and yeah,

#compdef platformio
_platformio() {
  eval $(env COMMANDLINE="${words[1,$CURRENT]}" _PLATFORMIO_COMPLETE=complete-zsh  platformio)
}
if [[ "$(basename -- ${(%):-%x})" != "_platformio" ]]; then
  compdef _platformio platformio
fi

is all related to the platformio system completion install command (it installs _pio if you use pio instead of platformio)… the 0.3.2 installer didn’t add it though, but I’m not running the beta on this system, so maybe that was it. Either way, I then also needed to add the platformio directory to the path… i.e. export PATH=$PATH:/home/pfeerick/.platformio/penv/bin … and then when I run platformio commands, it auto-completes commands or give suggestions on multiple options. Very nice indeed! :slight_smile:

1 Like

Could PIO’s new installer run platformio system completion install automatically instead?

Platformio starts quickly. I haven’t found any glitches :slight_smile:

1 Like

When I installed PIO on that system using the 0.3.2 installer, nothing was added to my .zshrc file - that snippet was only added when I ran platformio system completion install … (the corresponding _pio was added when I ran pio system completion install). This was after I added the ~/.platformio/penv/bin folder to my path, so that pio could be found.

Yes, we don’t add automatically PIO Core to PATH and do not enable shell completion. The reason is that we don’t have enough permission to do this. User should personally decide does he need these features or does not.

2 Likes

Снимок экрана от 2020-06-26 14-09-29

This began to happen again after updating VS Code

Do you see any errors in VSCode > Help > Console? Do you use antivirus tools?

just Installed and works like a charm…no issues till now.

1 Like

There are no errors, I do not use antivirus.
OS Linux mint.

The next beta of PlatformIO IDE for VSCode 2.0.0-beta.6 is out!

What is New

  • Added support for portable Python 3.8 for macOS
  • Added support for upcoming PlatformIO Core 5.0
  • Other improvements and bugfixes.

Upgrading to 2.0.0-beta.6

Please follow Install Beta steps in PlatformIO IDE for VSCode 2.0 Beta – Help us with testing!

Please note that you will need to update all dev-platforms via PIO Home > Platform > Updates or pio update to see new Platform tasks in explorer.


Regards,
Your friends at PlatformIO.

1 Like

There is a fix for this issue in pyserial master branch that has been waiting since May 2018 to get into a pyserial release. I downloaded the master branch of pyserial, uninstalled the pyserial from the platformio environment and then installed the master branch of pyserial into platformio. Now I can download to my Arduino even if the bluetooth serial ports are enabled (which is good because I’m using a bluetooth serial adapter on my Arduino to transmit data to my PC so I really need the bluetooth enabled). Hopefully this fix in pyserial will make it into a real release one of these days…now on to the next problem.