PlatformIO IDE 3.0 for VSCode 🚀

We are excited to announce a new major release of PlatformIO IDE 3.0 for Microsoft Visual Studio Code (VSCode) and provide embedded software developers with an advanced development environment that meets their evolving needs and demands. The new version of the IDE is built on the latest technology, delivering an enhanced user experience, improved performance, and expanded functionality compared to previous versions.

Your friends at PlatformIO.


@ivankravets Nice new features! THX.

Like the Custom PlatformIO Toolbar alot, tested works like a charm.
Is it possible to add a hover text like it is with the hardcoded entrys?

1 Like

In the release notes: “Added PlatformIO base commands to the Explorer context menu”

I really think you should undo this. As the name implies, a context menu is for commands specifically related to the thing you’ve right-clicked. Of the four commands you add to the Explorer context menu, three are global and redundant (PIO home, PIO core upgrade, and PIO open CLI); only the Rebuild IntelliSense Index command is potentially specific to the selected project (though it’s unclear to me whether it actually is context-aware).

All of those commands already have a home, so I think it’s a really bad idea to clutter up the Explorer menu, whose commands are very much file-management specific, with redundant, unrelated commands.

1 Like

Hi Antonio!
Thanks for the feedback. Agree with you. Fixed in

Have you declared the tooltip field? See

Thx, thats working fine!!!

1 Like

Yes, the example works fine. And so I came up with the idea of ​​building a reset button for the ESP32. So far I have pressed CTRL t + CTRL d twice in the terminal.
My code is:

            "text": "$(search-refresh)",
            "tooltip": "ESP32 Reset",
            "commands": [
                    "id": "workbench.action.terminal.sendSequence",
                    "args":  {

but that doesn’t seem to be the right approach. Is that even possible?

This is the terminal’s command, not “serial monitor”. The only option that comes to my mind is to create custom target and reset the board using PySerial API. Later, the custom task will be available in “Run task…”.

PlatformIO IDE 3.1.0 for VSCode is out!

  • Add support for the ${command:platformio-ide.activeEnvironment} variable that can be used in a custom PlatformIO Toolbar and VSCode variable substitution (issue #3588)
  • Focus on the project configuration output tab only on error (issue #3535)
  • Fixed an issue with a task runner on Windows 7 (issue #3481)
  • Fixed “Select All”, “Undo”, and “Redo” operations on macOS for PIO Home (pull #3451)
  • Fixed an issue when the “Upload & Monitor” task selects the wrong environment (issue #2623)

See PlatformIO IDE 3.1.0 for VSCode Release Notes for details.

Your friends at PlatformIO

1 Like

Good afternoon.
Tell me how to add an icon to the toolbar in version 3.1 “Upload and Monitor” ?

See docs for the platformio-ide.toolbar setting.

Thanks, it worked.
Is there any way to add an icon to this function?

Do you mean?

"text": "$(arrow-right)"

See also Product Icon Reference | Visual Studio Code Extension API

Thank you.
Everything turned out as I wanted.
Now, when programming microcontrollers, you can download and immediately open the port monitor with one button
Icons can be changed from the list
Product Icon Reference | Visual Studio Code Extension API
“text”: “$(run-all)”,
“tooltip”: “PlatformIO: Upload and Monitor”,
“commands”: “platformio-ide.uploadAndMonitor”


I have recently encountered an issue where the project switcher button does not do anything anymore after updating. It used to open a dropdown of available projects. I have tried restarting.

Any ideas?

Do you use the latest VSCode? Also, do you have any extra extensions?

Yes its the latest VSCode. I have Git extension pack and the C/C++ intellisense running

Could try to create another empty project? Could you reproduce this issue?

On creation of the new project it switched to the new project ‘test’ but clicking on the button still does not bring the drop-down to switch. I can switch projects through the Platform IO project menu and select the project I want so I can work around it.

So there was a github issue with the platform.ini file that needed to be resolved on one of the open folders. This was causing the issue. Sorted now thanks

1 Like