PlatformIO IDE 2.0 Public Beta and PIO Core 3.3

PlatformIO IDE 2.0 Beta 1 and PlatformIO Core 3.3 are released!

We greatly appreciate our PlatformIO Plus customers. We could not imagine these releases without their support! New features are coming soon!

Release Notes

PlatformIO IDE 2.0 Beta 1

  • Completely rewritten in React
  • PlatformIO Home
  • Library Manager
  • Board Explorer
  • Platform Manager
  • New PlatformIO IDE Installer
    • Asynchronous tasks
    • Compatible with Anaconda
    • Allowed disabling non-required Atom’s dependencies
    • No need to install Python on Windows
  • Added command/hotkey for PIO Core program target

Dark theme

Light theme

PlatformIO Core 3.3.0

  • PlatformIO Library Registry statistics with new pio lib stats command

    • Recently updated and added libraries
    • Recent and popular keywords
    • Featured libraries (today, week, month)
  • List built-in libraries based on development platforms with a new pio lib builtin command

  • Show detailed info about a library using pio lib show command (issue #430)

  • List supported frameworks, SDKs with a new pio platform frameworks command

  • Visual Studio Code extension for PlatformIO (issue #619)

  • Package version as “Repository URL” in manifest of development version ("version": "")

  • Improvements and bug fixes.

See PIO Core 3.3 Release Notes for details.


  • PlatformIO IDE: Please click on Settings :gear: in Toolbar and follow to Updates section.
  • PlatformIO Core: Please run pio upgrade command in a Terminal.

PlatformIO IDE

1 Like

This update breaks PlatformIO/Atom for me. After restarting atom, the edtior becomes unsresponsive, one Atom thread goes to 40% CPU load (on a quad core), memory consumption of this thread goes up until Atom crashes at around 2.4 GByte memory.

What I did:

  • Removed Atom and PlatformIO, did a clean reinstall of Atom -> Atom behaves properly.
  • Installed PlatformIO 2.0 Beta, restarted Atom -> Memory consumption goes through the ceiling again and Atom crashes

How can I install PlatformIO 1.7?

Could you the latest development build?

Open OS Terminal and run

apm uninstall platformio-atom-ide
apm install --production platformio/platformio-atom-ide

Thanks Ivan, will try this evening, when I’m back from work. Forgot to mention that I’m on Windows 10.

Problem solved, thank you!

1 Like

I cant seem to install platformio at all.
i followed the instructions in the docs and nothing happens. none of the menu items for platformio do anything.

I tried installing through cli and get:
C:\Users\Ryan>apm install --production platformio/platformio-atom-ide Cloning failed Installing modules done Cannot read property 'getReferenceTarget' of null

You don’t need to use a development version of PIO IDE 2.0. It was officially released in Atom registry.

  1. Settings :gear: > Packages > Search for platformio-ide and uninstall it.
  2. Settings > Install > Search for platformio-ide and install latest stable beta version.