PlatformIO Community

PlatformIO IDE 2.0 Preview


#21

Nope, it wasnt that!!

I was trying with the platformio IDE package. I removed the .atom, .platformio and the atom app and tried the whole thing with the latest vanilla atom package. Works fine without any issues…

:slight_smile:


#22

Could you explain in details?


#23

When I click on this menu:

I get an empty page:

Library Manager works when accessing from homescreen.

Robert


#24

Thanks, fixed!


PlatformIO IDE for Atom: Go To Declaration
#25

@Krishna_Chaitanya, @Robert_Walli, please upgrade to new development version which has internal auto-update mechanism. Also, installation instruction has been simplified to 1 command. See updated post above.


#26

Still get the unable to create virtualenv dialogue!!

Here is the screenshot.

I tried running the command with the existing installation and it threw the error.
Deleted the platformio-ide folder from .atom/packages and tried the command again and still the same error.
I tried running apm install . command from within the platformio-ide folder and yet the same error persists…

As another attempt I cloned the repo from git, renamed to platformio-ide and placed it in the .atom/packages directory (after deleting the existing directory), and this time it throws up this error.

UPDATE : Removed the entire platformio-ide from the .atom/packages folder and tried installing platformi-ide from within the atom package manager and yet the same error persists. - unable to create a virtualenv.


#27
  1. Close Atom
  2. Opem system terminal, run these commands:
rm -rf ~/.atom/packages/platformio-ide/penv
virtualenv ~/.atom/packages/platformio-ide/penv
source ~/.atom/packages/platformio-ide/penv/bin/activate
(penv) pip install -U https://github.com/platformio/platformio-core/archive/develop.zip

Now, start Atom.


#28

That did the trick!!
Thanks @ivankravets :slight_smile:

Any specific reason why python is harassing me like this??
I guess it must be a permissions issue.


#29

Please forget about this issue. I’ll rewrite PIO IDE 2.0 installer from the scratch, but later.


#30

Thank you anyway @ivankravets :slight_smile:
My apologies, if I came across as a rude ass. I am assuming that I did something wrong and hence the trouble what I am causing you.


#31

will the linter issues with .ino files be fixed? (renaming them/converting to cpp is not really an option for our project)


#32

Is it broken? It can not be fixed. We use PlatformIO-based GCC toolchains to lint a code. .INO is not valid C/C++ file format. It was invented for children and schools. Please note that PIO IDE or even Arduino IDE doesn’t use your INO files for compilation. We apply extra steps to convert INO to CPP “on-the-fly”. Sometimes it works, sometimes doesn’t.

We highly recommend to DON’T use INO because it is a useless file format.


#33

keep in mind those children in schools are the next generation of makers and software engineers :slight_smile:

we should do all we can to keep things simple for newbies and encourage them to learn. (but agreed: not handicap a system with burdensome and senseless crutches, either).

which btw - I freshly installed PlatformIO and was quite impressed with how easily I could compile code and send it to my ESP8266! Well done - I didn’t even need to specify the COM port. It just worked. First time. cool


#34

Thanks a lot for a feedback. That is only the Alpha build. We had a lot of unimplemented features for PlatformIO IDE 2.0. Stay tuned with us, you will be impressed!


#35

Hello, trying to give the v2.0 a try, however I get these errors and couldn’t google anything relevant:

Any ideas where to investigate / how to resolve?
Thanks


#36

@mbariola do you have GIT installed in a system? https://git-scm.com/downloads


#37

Used to, I swapped vanilla GIT for the GitHub GIT client to give it a go … http://desktop.github.com


#38

PlatformIO IDE 2.0 Public Beta has been just released! You don’t need to install, GIT, etc.

  1. Atom > Settings :gear: > Packages > Uninstall platformio-ide
  2. Atom > Settings :gear: > Install > Install platformio-ide

#39

Hi! It is 2k19 now, so isn’t playground feature realised yet? If it is, please tell me where I can find that.
Thank you!


#40

Not as far as I know… we’ve got Debug and Remote now… but not Sandbox, Settings or Project Wizard.