PlatformIO IDE 1.7.0

PlatformIO IDE 1.7.0 is released!

Release Notes

  • Added new Toolbar button to run other targets
  • Added new Toolbar button to toggle Build Panel
  • Added file specific icons to TreeView
  • Added Minimap with preview of the full source code
  • Fixed “Menu: PlatformIO > Install Shell Commands” for Windows
  • Fixed issue with “Uncought Error: Failed to get boards”

File specific icons and and Minimap

Button with quick access to other targets


Please click on Settings :gear: in Toolbar and follow to Updates section.

PlatformIO IDE


Hmm, The upgrade did not go smoothly and my platformio installation in bonked!!
I have tried removing the .atom and .platformio folders in the user directory.
I have tried uninstalling and reinstalling the platformio package from the website.
I have even tried the “apm remove platformio-ide && apm install platformio-ide”.

In all the cases, the installation completes, I see the platformio menu bar and I am even able to open the projects.
But I am unable to build any project - keyboard shortcuts or menu options. The platformio terminal does not showup.

What is your OS? Do you use the latest Atom?

MacOS Sierra
Yes, I downloaded the binary directly from
redownloaded it just to be sure.

Same problem, update failed and platformio-ide is broken, now i can’t uninstall.
Also on Mac Sierra. Generally I have problems with updating, because the ‘sudo’ is
missing in pio commands, that is the most times necessary to make a proper update.

mac-os sierra, atom .1.12.6
I manually deleted platformio-ide and reinstalled over the atom package manager, now it works.
I have installed a beta of pio before (3.2b2) maybe this causes the problem?

Just need to restart IDE after upgrade. No need to delete anything. I see this issue. I’ll think how to resovle it as soon as possible.

The restart was not the problem. After updating, the platformio-ide was broken and no restart help,
it was also impossible to delete platformio-ide from the package manager. Maybe the problem is
the downgrade from 3.2b2 back to 3.1 and a needed sudo command for changing the version.
I saw the restart issue when making the new installation after deleting.

I’ve just released PlatformIO IDE 1.7.1. Could you try update it again? It should work now without any problems.

Update works without a problem :slight_smile:

1 Like

I can confirm that!! The 1.7.1 works just fine!! :slight_smile: