PlatformIO Home tab stuck


#1

Updated PlatformIO on Windows 7 x64 and now the PlatformIO Home tab just shows a spinning circle.


#2

Please open PlatformIO IDE Terminal and type

pio home

What do you see?


#3

pio home
CorePackageManager: Installing pysite-pioplus @ >=0.4.2,<2
Warning! Package Mirror: HTTPSConnectionPool(host=‘akamai.bintray.com’, port=443): Max retries exceeded with url: /e9/e9bfbd9230a1ff33be6233ef36872f547613b26529
65d4c147dbc0c4e2722fde?gda=exp=1504838266~hmac=cd1d9c0f328eb97cacadfb1a9fd9558bf584e2e4fc6cea401f3935c3163c5f66&response-content-disposition=attachment%3Bfi
lename%3D%22pysite-pioplus-windows_x86-0.4.2.tar.gz%22&response-content-type=application%2Fgzip&requestInfo=U2FsdGVkX1-MTsPkQln9Vw43XbMDaeTOmgZ6VRTRTNpG1HxLQk0y
tBQ_iL8Q-DAEUgJhLWD6JW320Seu71HWfJApbrCSs_GdvY9dfwHLTKbxQSQ8-H1ccQsSwt_fJ2xC1SeZtb-_P1BOWlRXVb-ePTZy78rh39p7F31AgjHFloc (Caused by SSLError(SSLError(1, ‘_ssl.c:
504: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed’),))
Looking for other mirror…
Error: Could not install ‘pysite-pioplus’ with version requirements ‘>=0.4.2,<2’ for your system ‘windows_x86’.
If you use Antivirus, it can block PlatformIO Package Manager. Try to disable it for a while.


#4

Please provide an output from system Terminal cmd

echo %PATH%
echo %PYTHONPATH%
python --version
pip --version
pip list

#5

Just wanted to follow up with this as I am having the same issue. When I execute ‘pio home’ however I get:

PS C:\Users\name> pio home
PlatformIO Plus (https://pioplus.com) v0.10.11

  ___I_
 /\-_--\   PlatformIO Home
/  \_-__\
|[]| [] |  http://127.0.0.1:8008
|__|____|_______________________

and a browser tab opens properly showing what should be displayed in the IDE tab … any thoughts?

I added ATOM and PIOPLUS.EXE to network firewall settings (win10)

Thanks


#6

Solved my own issue (3 hours later … and 30 seconds after requesting help here!)

I had to go to the Firewall Rules and add outbound rule for:

%USERPROFILE%.platformio\packages\tool-pioplus\pioplus.exe

I just did Allow all … if anyone wants to help me limit the scope here I’m all ears!