PlatformIO Community

PlatformIO HOME Page can't open


#1

I want to use the PlatformIO for Atom,I installation that,but it can’t work
PlatformIO Home Page can’t open.I’ve tried the Windows 10-bits &Ubuntu 16.04 ,also not.
Ubuntu 16.04
clang 3.8.0
Python 2.7.12
Atom 1.21.0

WIndows 10 pro(15063)
clang 3.9.1
Python 2.7.14
atom 1.21.1
Visual Studio Community 15

platformIO home page is always loading


#2

Do you see any errors when type pio Home in PIO IDE Terminal?


#3

Hello, I have the same issue here, My PIO IDE terminal is ok.

I also tried to build the code, it keeps showing the following message forever:

PackageManager: Installing toolchain-xtensa @ ~1.40802.0
Downloading…

I tried many advices from the forum, no one really worked, so I installed the Arduino IDE. When I started installing the ESP8266 board from Boards Manager I realized that my internet connection is poor, because I had to restart many times the download until I complete it.

But since I cannot see the download status and I can’t control the pause/retrieve the download I really can’t see for sure what it is happening. I think that it might be interesting to show the status of the download (%) and also you can start the download from where it stopped…

Paulo


#4

Please remove %HOME_DIR%/.platformio folder and restart build when internet connection will be good.


#5

I have the same problem. I remember I had this happen once before, where half the buttons on the Platformio toolbar don’t work, including the home button. I remember I fixed it by modifying the permissions on a particular folder. It seems PIO was very particular about the permissions setting, but I can’t for the life of me remember what folder it was or what the permission state had to be. I thought I had posted it to this forum at the time, but I can’t find anything about it now. Now every time I start Atom a PIO window pops up saying it’s installing PIO core, and then another window pops up asking to restart PIO. Restart and the exact same thing happens again. Doing pio upgrade and pio update (from a terminal window, pio’s terminal button also doesn’t work) don’t fix it.
:frowning: Ian


#6

Forgot to mention, OS is Linux Elementary (Loki)


#7

Maybe http://docs.platformio.org/en/latest/faq.html#multiple-pio-cores-in-a-system ?


#8

I find the question ! I need to get out of GFW and make sure internet be connected