PlatformIO Community

PlatformIO hangs adding project dependency to AccelStepper library

Hello, I’m new to PlatformIO (VS Code, Windows10, node32s for this project) and enjoying it. I’ve installed a few Arduino libraries successfully but trying to install “waspinator/AccelStepper@^1.61” several times and every time it just hangs with a spinning circle on Add in the Add Project Dependency dialog. I’ve tried restarting VS Code and the computer several times. Also tried “pio update” and then “pio pkg update” to no avail.

Should I just follow the instructions for adding a library that is not registered (How to include Arduino Library in PlatformIO?)? Any thoughts are appreciated.

Hi,

Have you ever tried to download with lib_deps?
If not, try to write this in platformio.ini:

lib_deps = 
    https://github.com/waspinator/AccelStepper

Then, you should build your project and the output should be something like this:

In this way, platformio will add a directory with the library, and the project tree will be like this:
Captura de pantalla 2022-11-23 101454

Cheers,
RAR.