PlatformIO: Failed to run a command: Build

I’ve had PlatformIO installed for a while now, use very occasionally with arduino & esp32 (would like to use with WIZwiki-W7500 or the p version but that is getting ahead of myself…), made the mistake of running from the menu PlatformIO -> “update platforms, packages and libraries”, then “Upgrade PlatformIO core”, “Update Atom packages”, then noticed a button to do another upgrade, can’t remember text, anyway, now I have installed ATOM 1.13. x64, PlatformIO 3.3.0a10 is currently the newest version available.

The problem is now when I click on Build, I get a box pop up saying ‘PlatformIO: Failed to run a command: Build’, “Please make sure that 'build package is installed and activated.” ’

If I open up a shell outside of PlatformIO and type “platformio --version”, I get :
PlatformIO, version 3.2.1

which platformio gives :

So this is perhaps an indication that somehow I have two installations ?

Anyway, is there a way I can fix this build issue, I have no idea what is missing ?
Is there a log to show what is trying to be found ?
Or will I need to remove and install again ?

If anyone has any ideas / suggestions that would be great,
Many Thanks !

  1. You have multiple versions of PlatformIO in a system. Please remove duplicates. Open system terminal and run pip uninstall platformio (if you installed with pip).
  2. Click on Menu: PlatformIO > Home. Which is your version of IDE? OS?
  3. Click on Settings :gear: icon > packages. Activate build package.

@ivankravets, thanks for your help.

IDE is 2.0.0-alpha4 Core 3.30a10

OS is :4.4.0-21-generic #37-Ubuntu SMP Mon Apr 18 18:33:37 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

If I click on build within Settings icon> packages, my options are to Uinstall or Disable.

have done pip uninstall platformio, now get :

$ platformio --version
bash: /usr/local/bin/platformio: No such file or directory

1, pio --version should work now from PlatformIO IDE Terminal (see icon on toolbar)
2. Try to uninstall build package and restart IDE. PIO should install it again.

@ivankravets OK, so “pio --version” now gives
PlatformIO, version 3.3.0a10

Now, don’t have multiple platformio installations after pip uninstall.

Restarted IDE after uninstalling build, exited, restarted and it did PlatformIO IDE: Installing…
Prompted to “Reload now” which I did but still the same issue,

I click on main.cpp in a project and then click on the build from the icons at the top and still get :
‘PlatformIO: Failed to run a command: Build’, “Please make sure that 'build package is installed and activated.”

Something is wrong with your installation. I see that you switched to a development version of PlatformIO IDE 2.0. Could you try back to PlatformIO IDE 1.0? Let’s test if it works.

  1. :gear: > Packages > Filter platformio-ide (Git) > Uninstall
  2. :gear: > Install > Search for platformio-ide > Install

Do you still have problems?

OK, back to IDE 1.7.2, after restarting said Core Failed to retrieve !
Restarted atom and now looks good, Core 3.3.0a10

And I can compile again the ‘build’ error is gone !

THANKS :wink:

OK, fine! Now you should help us :blush:

Try to click on “Try PlatformIO IDE 2.0 Preview…”. You should see this button on Home screen. What do you see now?

Happy to try and help…
That was the button that I think that caused me to start this thread !
I see:
"Switching to PlatformIO IDE 2.0 Preview …
Please be patient and let the installation complete (see status indicator in the bottom corner)."
Dialog box: “Please re-start PlatformIO IDE to apply new changes”, clicked “Restart”

PlatformIO IDE: Installing
Please be patient and let the installation complete.

Again “Releoad now” button clicked, now I see:
IDE 2.0.0-alpha.4
Core 3.3.0a10
I see “1 deprecation”, click on it to see :

Deprecated calls
atom core (1 deprecation)
Assigning editor 1181’s height explicitly via position: ‘absolute’ and an assigned top and bottom implicitly assigns the autoHeight property to false on the editor. This behavior is deprecated and will not be supported in the future. Please explicitly assign autoHeight on this editor.
TextEditorComponent.measureDimensions - /usr/share/atom/resources/app.asar/src/text-editor-component.js:1011:20
TextEditorComponent.becameVisible - /usr/share/atom/resources/app.asar/src/text-editor-component.js:295:12
TextEditorComponent.checkForVisibilityChange - /usr/share/atom/resources/app.asar/src/text-editor-component.js:993:16
atom-text-editor.attachedCallback - /usr/share/atom/resources/app.asar/src/text-editor-element.js:87:22
- /usr/share/atom/resources/app.asar/src/atom-environment.js:826:33

if I ignore that and click on my main.cpp and click build from icons, I get the same error as before :

PlatformIO: Failed to run a command: “Build”, ‘Please make sure that “build” package is installed and activated.’

Tried to compile both arduino and mbed stuff.

I’ve just mailed you. Need detailed info. Thanks!

The message has been sent using this platform, see a top right corner for notifications.

I am facing same problem now, If you want any logs I can provide

  • What is your OS? Atom version?
  • Do you use PIO IDE Examples?

I resolved this problem by using command pallette(ctrl+shift+p) and using build option and afterwards my build button is working.

Ubuntu 16.04
Atom latest stable
and pio examples: NO

Do you have problem with stable PIO IDE 1.7.2?

I didn’t encounter before upgrading to v2, when I reverted back to stable and after restarting atom, I encountered it once

Please file an issue here Issues · platformio/platformio-atom-ide · GitHub

Sorry for huge delay, created a issue