PlatformIO Community

PlatformIO extension doesn't activate in VSCode

Hello, recently I cannot use the PlatformIO extension anymore. I’ve been using it for about 4 months but yesterday it randomly stopped working. I opened VSCode to work on a project but the extension icon didn’t appear on the left bar (also the upload, test etc icons on the bottom bar weren’t there). So I tried:

  • Uninstalling the extension, reloading, installing the extension;
  • uninstalling the extension and VSCode and reinstalling everything;
  • uninstalling the extension and VSCode, deleting every folder and file related to them, and reinstalling everything.

None of this worked. What can I do?

VSCode Menu > Help > Toggle Developer Tools > Console

Please provide an output or screenshot for the latest logs. Thanks.

Hello,

I have a similar issue.

I’m using PlatformIO on Windows 10 with VSCode version 1.73.1. Today (21.11.2022) I got an issue during an automatic update of the PlatformIO Core. To solve the issue I tried a new installation as follows:

  • Uninstall PlatformIO from VSCode Extenssions
  • Stop VScode
  • Remove the directory “C:\Users\xxxxxxxx.platformio”
  • Start VSCode
  • Install PlatformIO IDE v2.5.5 Extenssion

The installation terminated with the following error:

Error: Error: Compatible PlatformIO Core not found.
Reason: Could not run C:\Users\xxxxxxxx\.platformio\penv\Scripts\platformio.exe --help.
Error: Error: Traceback (most recent call last):
File “C:\Users\xxxxxxxx.platformio\penv\lib\site-packages\platformio_main_.py”, line 102, in main
cli() # pylint: disable=no-value-for-parameter
File “C:\Users\xxxxxxxx.platformio\penv\lib\site-packages\click\core.py”, line 1130, in call
return self.main(*args, **kwargs)
File “C:\Users\xxxxxxxx.platformio\penv\lib\site-packages\click\core.py”, line 1054, in main
with self.make_context(prog_name, args, **extra) as ctx:
File "C:\Users\xxxxxxxx.platformio\penv\lib…

Kind regards

What are your VSCode settings? Did you disable the built-in PlatformIO Core? Please check VSCode settings and RESTORE to the default state all PlatformIO IDE settings.

Hello Ivan,

thank you for the feedback.

I don’t have any special settings in VSCode. It is a default installation.

At 18:30 CET I started my VSCode again and the PlatformIO extenssion was busy about 3 minutes with “PlatformIO: Loading tasks…”. Now everything seems to work like yesterday.

Kind regards
Michael

PlatformIO was installing project dependencies that used an Internet connection. The upcoming PlatformIO IDE 3.0 for VSCode improves UX and shows more details.

1 Like

Hello,

the last 3 days it was possible to work with PlatformIO without any issues.

Today at about 19:15 CET I got the same issue as 4 days ago. Wenn I start the the VSCode, the following activities will be show in the bottom right corner:

Pic

After restart of VSCode the same sequence is processed again.

Kind regards
Michael

Please provide an output or screenshot for the latest logs. Thanks.

Sorry for the late answer. This is a screenshot of the console when opening VSCode:
immagine_2022-11-25_165813842