PlatformIO Community

PlatformIO does not show boards when making a new project in clion

Hey guys,

I already used platformIO with Visual Studio Code and now tried to integrate it into Clion. But when I want to open some new project, I can not chose any board (first picture)
The windows changes a little bit, when I name the project, but I still can not create a project (second picture):
platformIO

Thank you!

It says “PlatformIO utility not found”. When you open a shell (cmd.exe) the pio command is not available right?

Yes, so I did not install platformIO correctly?

Since you’ve installed PIO with VSCode the PIO core probably isn’t added to the PATH automatically, allowing the program to be found. Can you open VSCode then a PIO shell and get the output of

where pio

?

When I start visual studio code and type “where pio” in the powershell terminal, nothing happens.

If I type it into the cmd, the following happens:

2020-03-29 16_19_50-Window

Oh so PIO does seem available under the path C:\Users\and\.platformio\penv\Scripts\pio.exe?

What happens if you just run pio --version?

It shows the version (4.3.1)

I now also tried it in the Clion terminal, here it only shows:
“INFORMATION: Es konnten keine Dateien mit dem angegebenen Muster gefunden werden.”
which roughly means: “Info: Could not be found”

oh wow, now it works.

So, my error was, that I made some typing error for the system path yesterday and now I just booted my computer again and Clion got it now…

But thanks a lot!

1 Like

I have this exact issue, but on my Linux machine. I already had CLion (latest 2020 version) installed and I installed the PlatformIO plugin. Then I got to this error, after some searching I noticed the platformIO core needed to be installed still, did that and added the installation dir to the system path. I can run pio just fine from the terminal. CLion however still can’t find it, is it not simply looking for the pio binary?

Thank you in advance, Vincent

1 Like

I too have the same problem.

Have you made sure to install PlatformIO in the CLI and also that it’s being accessible from the CLI?

Yes I have. I can access it with the terminal. Even with the terminal that comes with CLion.

Does pio boards return a good list of boards when called from the CLI?

Can you provide a screenshot of what you see when it’s not working?

Screenshot from 2020-07-30 12-01-59
This is what I see when I try to start a new project.

The pio boards command returns the list of boards when accessed from the terminal

Did you reboot the computer after applying the PATH changes or restart CLion? If pio works in the Windows terminal and in the CLion terminal I don’t see a reason why it would say “utility not found”.

Yes I did but still no luck.

Then it’s inexplicable to me. Try asking @ivankravets here or at https://github.com/platformio/platformio-core/ (I don’t seem to find a repo for the PIO CLion Plugin :/)

1 Like

@maxgerhardt Here you go : https://github.com/JetBrains/intellij-plugins/tree/master/platformio

Just tried with a fresh install of Clion 2020.2 under Ubuntu 18 with the latest version of the PIO plugin and didn’t have any problems. @gian2705 have you tried uninstalling the plugin, reboot, and re-installing the plugin ? (and the “ini” plugin required in addition to the PIO plugin ?)

1 Like

Yes. I just tried that and it still does not work. I’m currently using Ubuntu 20.04.1 and CLion 2020.2

Just found a similar issue here, author suggest to move your PIO system path declaration into “.profile” instead of “.bashrc”. Not sure it could help in your case.

2 Likes