PlatformIO build not happening in Atom

I am new to atom and platformio.

When i am trying to build example files in atom for Espressif 32 , i am getting the following error.

‘platformio’ is not recognized as an internal or external command,

operable program or batch file.

Unable to execute: platformio

Make sure cmd:‘platformio’ and cwd:‘C:\Users\Balaje K\Documents\PlatformIO\Projects\191022-152244-espidf-blink’ exists and have correct access permissions.

Binaries are found in these folders: undefined

But when i am trying to use platformio from command promt its getting executed.

If i try the terminal in atom for pio i am getting the following error.
pio --help
pio : The term ‘pio’ is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct
and try again.
At line:1 char:1

  • pio --help
  •   + CategoryInfo          : ObjectNotFound: (pio:String) [], CommandNotFoundException
      + FullyQualifiedErrorId : CommandNotFoundException

I don’t think there must be a gap in the path of the system.
‘C:\Users\Balaje K\Documents\PlatformIO\Projects\191022-152244-espidf-blink’

‘Balaje K’
Try a user without spaces.


I tried changing to different username without spaces and still facing the same error.

I tried installing platformio on my W10 computer, and took a blinking sample.
It compiled without any problems.