`PlatformIO: Build` does nothing in vscode

VSCode 1.85.2 - macOS
Platform IO IDE v3.3.2

Whenever I click on the “build” checkmark at the bottom of the screen, nothing happens aside from the command palette popping up with “PlatformIO: Build” in it.

Screenshot 2024-01-21 at 13.54.42 PST

If I hit “return” still nothing happens. Other commands like “home” and “update” appear to work fine, it’s only Build that doesn’t do anything. Not seeing any obvious output that would indicate why this isn’t working. Anyone have any thoughts?

Silly question, you do have a folder or workspace opened in VSCode, which has a platformio.ini at the top level?

Does the Mac equivalent of CTRL+ALT+b, which executes a Platformio: Build on Linux in VSCode, work?

Other than that, I’ve never come across this before. Plus, I’ve never event used a Mac of any flavour in the past.


I’m seeing the same thing / something very similar.

The Build, Upload, Clean, Test, and Serial Monitor buttons do nothing. And neither do their equivalent keypresses or menus. I’ve also tried Verbose Build from the Advanced menu and that does nothing at all.

This was working fine until a day or so ago, and I’ve not knowingly changed anything. (I’ve tried uninstalling and reinstalling PIO but that hasn’t helped.)

I appreciate I’m light on detail here, so please let me know how to generate more information that might be helpful. At present, I’m rather in the dark on how to proceed.

I installed VSCode and PlatformIO on another PC, just in case.

The code in my repo had:

framework = arduino
platform = espressif8266
board = d1_mini ; 4 MB flash

and this built correctly. I then made the same modification I’d made on the first PC but not committed:

framework = arduino
platform = espressif32
board = lolin_s3_mini ; 4 MB flash

Platform IO proceeded to download a bunch of stuff but is now stuck on “PlatformIO: Configuring project: Downloading 0%”, and if I try to build, I get “command platfom-ide.build’ not found”.

Something similar happened on the first PC before it got into the completely unresponsive state I described above, but I had not let myself believe it was related.

Does this offer any important clues to the crowd?

ETA: as I posted, VSCode transitioned to “PlatformIO: Configuring project: 10%” and stopped there

I had this problem, and it turned out that I had changed the setting “task.autoDetect” to off, because I was getting irrelevant tasks in that context. Took a long time to figure out, and 10 seconds to fix, so it’s probably worth it to check that you have the right value. If you have it set to off, the build, etc. UI and functions are still there, they just don’t connect to anything.

Thanks, @jwhitlark.

I’d not touched this and it was still “on”. I tried toggling it just in case, but no change :frowning:

I’ve changed nothing. And now it works. Computers are supposed to be deterministic! :face_with_diagonal_mouth: