PlatformIO Community

Platform IO Installation Issue, VS Code is "Unable to determine what CMake generator to use..."

Hi, I just installed PlatformIO IDE. I now get the error mentioned in the Topic Title. have not been able to find a solution for this, Appreciate any ideas on how to resolve or should I just ignore it?

I created new project for an Arduino, do I need to edit the VS code settings and point CMake to a particular file?

Thank you!

It seems like you have conflicting plugins installed?

Please show a screenshot of the error message, your installed extensions, and the platformio.ini of the project.

Looks like you are correct, I decided to completely remove studio, and start from scratch…Hopefully that will correct the issue.

Thank you!

Hey I would like to warm up this thread.
Same issue here.
I reinstalled cmake, c++ and vscode with platformio. Still get this error :confused:


The PlatformIO extension does not need CMake. Please disable the CMake extension for PlatformIO projects / workspaces.

1 Like

Yes, thanks - that solved the issue!