Platfomio Upload success but Program is not on controller

I’m new to Platformio.
The upload seems to be OK, I get the message “Success”, but the program is not on the controller. Same problem with Arduino uno and Adafruit Metro M4 Express, with Visual Code and Atom.
I have no other error messages, the serial monitor with the previous program on the controller runs without problems, the upload with Arduino IDE runs without problems on both cards.
What is missing in the configuration of platfomio.ini or what am I doing wrong?

How do you see that the program is not running?

Let’s focus on the Uno first, what’s the platformio.ini and code, what’s the expected output?


it is just simple code for test:

#include <Arduino.h>
void setup() {
  pinMode(13, OUTPUT);
void loop() {
  digitalWrite(13, HIGH);
  digitalWrite(13, LOW);
  digitalWrite(13, HIGH);
  digitalWrite(13, LOW);  
  Serial.print("Hello, I was uploaded with VS PlatformIO");


platform = atmelavr
board = uno
framework = arduino
monitor_speed = 9600
monitor_port = COM6

Your output should appear after roughly 6.5 seconds then. What’s the output when you run the project task “Upload and Monitor”? You’ve also verified that you’ve selected the correct project via the selector mentioned in in the link?

I see serialprint from old sketch , uploaded with arduino ide.

Hm there’s an error message reading “Window cannot be put to the wanted row- and column number” that I’ve never seen before.

Can you post the output of just the “Upload” task?

can you give me a tipp how/where i can find report of uploading, the lines running to quckly,
at the end i just see this:

Fenster kann nicht auf die angegebene Zeilen- und Spaltenanzahl gesetzt werden.
[SUCCESS] Took 8.17 seconds

Terminal will be reused by tasks, press any key to close it.

Did you select a different default shell in VSCode? I’ve not yet seen that happen before.

See bash - VSCode Change Default Terminal - Stack Overflow and try and select a different one.

What other extensions are installed?

I’v dont change the shell , it was windows powershell by default. I’v tried another two in the list , but no effect

The C++ Intellisense extension by ausin is on the “Conflicting with PlatformIO” list regarding Intellisense, the Microsoft one is correct. You should remove it if you don’t need it. Also not sure about “Better C++ Syntax”.

But it shouldn’t cause that error. it’s weird how there’s 0 output-

Also this looks like Windows 7? Hm.

@ivankravets maybe you have an idea of the “Fenster kann nicht…” →

error and no output from the Upload task except “Success”.

I uninstalled the extensions you mentioned(“C++ Intellisense by austin” and “Better C++Syntax”) , no effect. Yes, it runs on Windows 7 Pro, it seems to me,with my little experience ,maybe(maybe not) to be a global problem on my system , because after the visual code failed at the beginning, I have installed Atom with Platformio without any further add-ons, same result. There was no notification, but I made exceptions for vs and project order for Kaspersky with no effect.I have no Idea at the moment what else can i check.

I also encountered the same problem, is there any solution?