PIO with VS Code on Win7 working?

Does anyone have PIO/VS Code on Win7 running without the PIO home page error. I have tried several times to get it running. I have posted the problem here more than once, but it is still not resolved. It runs fine on my win10 machine, but not on win7.

Please, let me know if you have it running on Win7.

I just want to know so I can determine if it is just my setup or something that is broken in PIO/VSC wrt win7. I continue to see others with Win7 install issues, but don’t know if they have them resolved or have just given up.


Please provide an output from system Terminal cmd

echo %PATH%
python --version
pip --version
pip list

echo %PATH%
C:\Users\jhe.platformio\penv\Scripts;c:\Software\octave3.6.4\bin;C:\Program Files (x86)\Qucs\b
in;C:\ProgramData\Oracle\Java\javapath;C:\Program Files (x86)\Linaro\gcc-linaro-arm-linux-gnueab
i-2012.03\bin;C:\cygwin64\bin;C:\Python27;c:\Program Files (x86)\Intel\iCLS Client;c:\Program
Files\Intel\iCLS Client;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\Syst
em32\WindowsPowerShell\v1.0;c:\Program Files (x86)\Hewlett-Packard\HP Performance Advisor;C:\Pr
ogram Files\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files\Intel\Intel(R) Mana
gement Engine Components\IPT;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components
DAL;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files\Tort
oiseSVN\bin;c:\Program Files (x86)\Microsoft SQL Server\90\Tools\binn;C:\Program Files\Agilent
IO Libraries Suite\bin;C:\Program Files\IVI Foundation\VISA\Win64\agvisa;C:\Program Files\IVI Fo
undation\VISA\Win64\bin;C:\Program Files (x86)\Agilent\IO Libraries Suite\bin;C:\Program Files (
x86)\IVI Foundation\VISA\WinNT\agvisa;C:\Program Files (x86)\IVI Foundation\VISA\WinNT\bin;C:\Pr
ogram Files (x86)\IVI Foundation\VISA\WinNT\Bin;C:\Program Files\IVI Foundation\VISA\Win64\Bin
;C:\Program Files (x86)\Git\cmd;C:\Program Files (x86)\mingw32\bin;c:\iverilog\bin;c:\iverilog\g
tkwave\bin;C:\Program Files (x86)\IVI Foundation\IVI\bin;C:\Program Files\IVI Foundation\IVI\bin
;C:\Program Files (x86)\MATLAB\MATLAB Compiler Runtime\v716\runtime\win32;%USERPROFILE%.dnx\bin
;C:\Program Files\Microsoft DNX\Dnvm;C:\Program Files (x86)\Windows Kits\8.1\Windows Performanc
e Toolkit;C:\Program Files\Microsoft SQL Server\110\Tools\Binn;C:\Program Files\Git\cmd

C:\Python27;C:\Program Files (x86)\Keysight\Command Expert;C:\Program Files (x86)\Keysight\Comm
and Expert\Addons\python

python --version
Python 2.7.6

pip --version
pip 9.0.1 from c:\users\jhe.platformio\penv\lib\site-packages (python 2.7)

pip list

DEPRECATION: The default format will switch to columns in the future. You can use --format=(lega
cy|columns) (or define a format=(legacy|columns) in your pip.conf under the [list] section) to d
isable this warning.
arrow (0.10.0)
bottle (0.12.13)
certifi (2017.11.5)
chardet (3.0.4)
click (5.1)
colorama (0.3.9)
idna (2.6)
lockfile (0.12.2)
pip (9.0.1)
platformio (3.5.0b3)
pyserial (3.4)
python-dateutil (2.6.1)
requests (2.18.4)
semantic-version (2.6.0)
setuptools (36.5.0)
six (1.11.0)
urllib3 (1.22)
wheel (0.30.0)
py:318: SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication)
extension to TLS is not available on this platform. This may cause the server to present an inc
orrect TLS certificate, which can cause validation failures. You can upgrade to a newer version
of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/secu
py:122: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib
3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgr
ade to a newer version of Python to solve this. For more information, see https://urllib3.readth

Well I updated to Python 2.7.14, the latest, vsc and pio. It now appears to be working!

Thanks Ivan.

I had that problem for a long time. There is a thread on this forum covering it up.

Basically it was PATH problem. You need to check your PATH and reboot.