PIO & VSCODE - Home doesn't load - Unknown Package


#1

Hello,

I am having difficulty getting the PIO extension to run inside VSCODE. When trying to load the PIO Home page, I get a “Loading…” message before eventually it fails and an error is displayed. The Home screen never loads.

Error: Detected unknown package
'C:‘Users/jmorga34/AppData/Roaming/SPF_DATA.platformio\packages\tools-scons @ *’
Source: PlatformIO IDE (Extension)

image

What I have tried so far, including a few things I found by searching similar issues and resolutions from other users:

  1. Completely uninstall VSCODE and PIO extension
  2. Fresh install of VSCODE & fresh install of PIO extension
  3. Completely disable firewall to check if firewall is issue

System Info:
Windows 7 x64
VSCODE System-Install x64 v1.28.2

Any ideas of what to try next?

Thanks very much!
Joshua


#2

Please open PIO IDE Terminal and type

pio home

Do you see any errors?


#3

Yes I do:


#4

What is your HOMEDIR? Did you change system environment variables for USER_PROFILE, etc?


#5

image

See above. Any other env vars I should check? What should they be set to?

Directory contents of %USERPROFILE%:

image


#6

I was able to find a tar ball of tool-scons v2.20501.4 and manually upgraded the package files. This got over the tool-scons package issue, but now I have the same issue with tool-unity:

This indicates to me that the problem is less to do with the specific package, and more to do with the overall install or upgrade process.

Thanks for the help so far - really hoping to get this resolved soon!


#7

Have you resolved this issue?


#8

No I have not. After manually upgrading the tool-scons package, I encountered the same issue with every other package in the directory. Manually updating the packages by placing the updated files sourced online into the directory band-aided the problem temporarily. It now seems that the problem has returned (presumably something else got updated which made the manually-updated tool-scons package obsolete).

It seems that there is something preventing my pio install from accessing the web to upgrade the dependent packages (?). I have tried completely disabling firewalls in an attempt to troubleshoot with no success.

Any ideas of what to try to narrow down the source of problem?

Thanks,
Joshua


#9

It is a classic issue with permission. Do you antivirus system or firewall? Defender?


#10

Yes, I have corporate firewall and permission manager. Any idea to track down whether it’s a permission issue (eg. needs admin rights) vs a firewall issue? VS Code is currently set to be allowed through the firewall. Any other rules I should set? I don’t see entries for pio. If I can trace down whether it’s firewall or permissions, I can probably resolve.

Thanks!


#11

You need to have access to dl.platformio.org:80 or dl.platformio.org:443.