PlatformIO Community

PIO test filters not working?

Hi, I’ve used filters for unit testing on version 5x without problem,
now I’m testing same project on version 6.0.1 but seems filters are broken?
also created new project and got the same results.
sample command:
pio run -e native -f test1
should only run test1 file but it seems that the filter is ignored all together.
the output is like this;

ali@Air ~/d/n/esp32> pio test -e native --filter aaa                                                                                               master-!?
Verbose mode can be enabled via `-v, --verbose` option
Collected 1 tests

Processing * in native environment

I thnk you mean pio test here.

Should work according to docs. If it does not work after updating by using the CLIpio upgrade --devpio test -e native -f test1, please file an issue at Issues · platformio/platformio-core · GitHub.

I thnk you mean pio test here.

yeah

Should work according to docs. If it does not work after updating by using the CLIpio upgrade --devpio test -e native -f test1, please file an issue at Issues · platformio/platformio-core · GitHub.

updated to 6.0.2a1, same problem, I’ll create an issue then

Processing * in native environment

There is no “aaa” test. Please read updated docs Project Structure — PlatformIO latest documentation

A test folder must start with the test_ prefix. Otherwise, PlatformIO treats this folder as a group of tests.

1 Like