PlatformIO Community

PIO remote on RPi issues

I purchased some raspberry pis to act as remote agent for pio, and they have worked well. I recently had to upgrade to core 4 and am now having many python 2/3 issues. To what extent does pio still depend on python2.7? I have tried to set it on python3.7 only and it just doesn’t run. To account login I need 2.7, to start the remote agent I need 3.7, to upload I need 2.7…
I had to upload Ivan’s most recent .dev version and run a virtual env just to get anything running… what is the plan for removing all 2.7 dependencies?

We dropped support for Python 2.7 for PIO Remote. A lot of issues related with Unicode. We recommend using the latest Python 3. There is also plan to remove support for Python 2.7 from whole PlatformIO Core next year. Python Foundation does not maintain Python 2 branch more.

How to resolve your issues? It’s very easy:

  1. Uninstall ALL PlatformIO Cores from system https://docs.platformio.org/en/latest/core/installation.html#uninstall-pio-core-and-dependent-packages
  2. Remove ~/.platformio/penv fodler
  3. Check that python3 --version works.
  4. Run installer script https://docs.platformio.org/en/latest/core/installation.html#installer-script