PlatformIO Community

PIO remote have multiple bugs

Host machine: MBP 13" 10.14.6
Agent: Raspberry Pi 3B+
PIO Plus: 2.5.8
PIO: 4.0.3

I’ve noticed that PIO Plus has been pushed to 2.5.8 and it has introduced multiple bugs that were not present previously, namely:

When checking for the list of agents from host, pio remote agent list, the remote agents are always named as ‘name’ on output, however, using the remote upload to specific agents using their actual names still work, e.g.:

On agent:
pio remote agent start -n agent

On host:
pio remote agent list will output name
pio remote -a agent run -t upload .... will still work as intended and compile/upload code just fine

I did not test with multiple agents

Second bug:
pio remote -a agent device monitor no longer works but triggers an agent list command instead (can be seen in the service monitor) and outputs a odd looking agent id, e.g.:

pio remote -a agent device monitor outputs hwid

I suppose this is some weird serialisation of name, but it doesn’t change when run with different flags stating the port and baud rate — shouldn’t matter anyways because it seems to be triggering a device list vs the remote monitor

I’ve been using pio remote for some time now to remote upload code / check serial output and these are breaking changes to my workflow. I last tried in late August / early Sept.

Thanks for the report! The bug was fixed. Please run pio update on the agent and remote machines, restart PIO Remote agent.

Does it work now?

I’ve updated both to core 4.1.0 and ran pio update to 2.6.0

Now I’m getting an error:
sequence item 1: expected str instance, bytes found
when I run both pio remote agent list and pio remote device list

On the remote end I’ve noticed that I do receive the request for device but not for the agent

The device monitor bug doesn’t seem fixed either:

Here’s the complete command and logs. My agent is named ‘prusa’
$ pio remote -a prusa device monitor
PIO Plus (https://pioplus.com) v2.6.0
‘hwid’