PIO Reconnecting

Hi there,

PIO is consistently showing the reconnecting message - how do I fix this?
Happy to provide any info you require!

I’ve never seen PIO do that. What other extensions do you have installed?

hey, thanks for your reply, I’m relatively new to using VS+PIO (dumb it down a bit), however, I think you are referring to the following:

From a google search, I found a couple of threads from here but those don’t seem to be the same issue?

OK! Reinstalled it and restarted PC (hasn’t been restarted in about a couple of months), this seems to have solved it.

I lied! It’s back at it, to add to it, a fresh install of VS Code on a mac + PIO compiles projects without a problem, however this one is now throwing up many errors + the reconnecting blurb on the home screen, any help ? :slight_smile:

Do you see the PIO Home website when you visit in your normal browser?

In a CLI, what’s the output of pio home?

Nope, I did a complete wipe of the VS Code install and deleting these: %APPDATA%\Code and %USERPROFILE%\.vscode.

Searched for that link and it does not load, however PIO now loads and still has errors compiling a project I was instead working on the mac (new install, literally nothing fancy, both loading projects from the same NAS location).

When I compile this project I get the following errors:

Again, this compiles and flashes to ESP without a problem from the mac. Could there be some libraries missing? Its been years and years since I did any embedded work so please take it easy :slight_smile:

Funny thing is, as I was typing the post above I was answering your questions and as I got a CLI session up and did what you asked, it actually worked and loaded the home page!

however still compile errors on this machine.

FYI machine is a Win 11 upgrade from 10.