Pio not found on Ubuntu 15.10 [solved, but can't repro]

I tried using the installer script and using sudo pip install -U platformio. Both of them don’t install the scripts pio or platformio to any location in my $PATH.

I was able to resolve that by using this command sudo pip install platformio -U --install-option="--install-scripts=/usr/local/bin", which forces pip to install platformio to /usr/local/bin. After executing this command once I can’t reproduce the original behavior and even after a uninstall of platformio the sudo pip install -U platformio command works as expected.

Since this is a quite weird and irritating issue & solution I thought it’s the best to post it here, in case anybody else runs into it.

If anybody has an idea on how I could try to reproduce this issue I’d be willing to try it.

➜  ~ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 15.10
Release:        15.10
Codename:       wily

I had trouble because I was behind a proxy. So I had to use the --trusted-host option:

OS: Ubuntu 16.04

sudo apt-get install python-pip
sudo pip install --trusted-host pypi.python.org --upgrade pip
pip install --verbose --trusted-host pypi.python.org platformio