Pio home won't open after latest update on vscode backports.functools_lru_cache

it won’t open…

C:\Users\cmf\Documents\PlatformIO\Projects\KLine>pio home
Traceback (most recent call last):
  File "main.py", line 13, in init main
  File "c:\users\cmf\.platformio\penv\lib\site-packages\platformio\maintenance.py", line 25, in <module>
    from platformio.commands.lib import lib_update as cmd_lib_update
  File "c:\users\cmf\.platformio\penv\lib\site-packages\platformio\commands\lib.py", line 22, in <module>
    import arrow
  File "c:\users\cmf\.platformio\penv\lib\site-packages\arrow\__init__.py", line 3, in <module>
    from .arrow import Arrow
  File "c:\users\cmf\.platformio\penv\lib\site-packages\arrow\arrow.py", line 19, in <module>
    from arrow import util, locales, parser, formatter
  File "c:\users\cmf\.platformio\penv\lib\site-packages\arrow\parser.py", line 12, in <module>
    from backports.functools_lru_cache import lru_cache  # pragma: no cover
ImportError: No module named backports.functools_lru_cache

C:\Users\cmf\Documents\PlatformIO\Projects\KLine>pip install backports.functools_lru_cache==1.2.1
Requirement already satisfied: backports.functools_lru_cache==1.2.1 in c:\users\cmf\.platformio\penv\lib\site-packages


Please remove folder above and restart IDE.

Hi Ivan. I have done that, and while I do not see the same error any more, it still doesn’t open.

i still get ‘timeout’ trying to open it. if I then type “pio home” from the terminal, nothing happens. no error either.
but when launching VSCode, or clicking the Home icon at the bottom, it takes a while then gives a timeout :frowning:

It’s working now. Seemed to be a problem with my separate Python installation in Windows.