PIO Home not loading in VSCode

Hi everyone!

I’m having some issues running the PlatformIO IDE on my work computer, I’m having the following error after installation:

Error: Could not start PIO Home server: Error: timeout
    at c:\Users\REL2CT\.vscode\extensions\platformio.platformio-ide-2.5.4-win32-x64\node_modules\platformio-node-helpers\dist\webpack:\platformio-node-helpers\src\home.js:199:13...

The error message seems to not be complete, but I can’t find a way to show the complete one, and the check available solutions button does not help, for some reason, I can’t get any response from opening localhost:8008 on my browser, as when I run the pio home command, it outputs PlatformIO Home server is already started in another process. I tried changing the port, but it now gets stuck at:

Open PlatformIO Home in your browser by this URL =>
Tool Manager: Installing platformio/contrib-piohome @ ~3.4.2

I`ve looked on the forums for help but I did not find similar problems, and when I tried the solutions they (kinda unsurprisingly) didn’t work aswell, so now I’m reaching for help. Can anyone give me some help please?

Thanks in advance!