PlatformIO Community

PIO Home errors on a Mac

I cannot install a library in my project using PIO Home.
I created a new project with the “New project” button and then when I want to install a project library, strange things happen:
Sometimes when I click “Libraries”, I cannot type into the search field at all; nothing happens when I type.
Some times when I type, the characters appear on strange places on the screen, not in the search box, but in the explorer sidebar after the line with “> .pio”
Sometimes I can search and the library is found. I then click “Install” and in the submenu “Install to” a list of projects appears, but the project I just created is not in the list.
Sometimes (after I have restarted VSCode) the project is in the list and seems to be installed, but it actually is not installed at all. It does not appear under the .pio libdeps and I get compile errors (lib header file not found).
I work on a Mac, MacOS 10.15.1
PlatformIO version: Home 3.0.0-beta.3 Core4.1.0rc3

It seems like this issue?

1 Like

Sounds like you have two somewhat related issues

  1. the one Ivan pointed out, in relation to keyboard focus - which has been reported numerous times since it reared it’s ugly head in the July/August VSCode build - and we are still waiting on the Microsoft devs to identify the cause and fix it.

  2. are you referencing the library in your platformio.ini lib_deps entry? As if you have, it will be automatically installed if it is missing.

I think there may be even three issues:

  1. the keyboard focus issue
  2. PIO Home not being able to find the project or update the project list
  3. PIO Home incorrectly reporting to successfully installing the lib

BTW: if I add a lib_deps entry in platformio.ini the library installs just fine.

1 Like

True :wink:

I can’t really comment from experience re 2 & 3, as I basically only open PIO to start a new project, and the few times I remember that libraries and boards can be searched for that way… rest of the time I have a search bookmark for the PIO registry and a web browser already open… really should remember to use it since it’s only a click away in the status bar! Plus I’m on windows/linux, and you could have found something Mac specific.