Pio Home button missing after installing - No platformio errors seen on console - No .platformio folder

Hi, i installed platformIO from Vs code extesion. i’ve got the prerequisites of C/C++ extesions installed and the extension just doesn’t change anything. i looked after this bug/error and all people show some error in the console, mine looks well i gues? no line referring to platformio.

Also the platformio folder “.platformio” didn’t appears where it should be. i tried reinstalling the extension multiple times and nothing seems to work out.

The only one that’s needed is C/C++ by Microsoft. CMake is not one of them.

Please show the list of all installed extensions.

-C/c++ extension pack ( contains some of the ones below).
-Cmake Tools.

  • Platformio IDE

I’d recommend deleting those. You won’t need them if you just use PlatformIO.

okay, done. now where should i continue from? i uninstalled the extensions, reload the window and now looked out the console again. onyl this warning showed up:

Via ‘product.json#extensionEnabledApiProposals’ extension ‘github.vscode-pull-request-github’ wants API proposal ‘commentsResolvedState’ but that proposal DOES NOT EXIST. Likely, the proposal has been finalized (check ‘vscode.d.ts’) or was abandoned.

What’s the VSCode version? Also I’ve never seen the top bar of VSCode look like that.

im on windows 11 and the version is 1.75.1. It’s not the MS version, i downloaded the installer from the vs code page.

EDIT: probably is beacause i got the c/c++ themes extension installed. idk if it changes anything. probably yes. I’ve always used it so i can’t tell the difference.

So from where exactly?

I’m not seeing a “Electron sandbox is enabled!” message in my VSCode. Did you do something to explicitly enable it?

What’s the output of the Output → Extension Host tab? Does it say anything about the extensions it wants to start?

Have you tried restarting VSCode? With e.g. Ctrl+Shift+P → Reload Window.

Download page: Download Visual Studio Code - Mac, Linux, Windows

“Electron sanbox is enabled” message. i looked after and aparentelly is something of vs code. i reinstalled the program today so must be arround that. No, i didn’t do anything in particular to make it appear enabled.

Reload window. Yes. I’ve tried that and had no luck. every time i changed a configuration i reloaded the window.

images of output> extension host.

second image. i only can post one at a time…