PIO Home bug when updated to latest version

There’s either a bug in PIO home screen or me. I was showing someone yesterday and I couldn’t put the cursor in the search libraries box to search for anything. I was extremely fortunate that the recent suggestions had what I needed!

Set it all up today on a laptop and same thing again. I closed the PIO home tab and then using the menu on the left opened it again and search box works from there. I tried to recreate by closing visual studio code and reopen, but PIO home auto opens and now behaves. That’s all a bit weird and nothing more than a minor inconvenience.

Actually, I can reproduce it. On reopening the IDE although cursor is in the search box which has focus I can’t type anything. I tried my previous trick of closing the tab then reopening and now I can search. I’m fairly certain now its not my imagination.

It’s a known bug that needs to be fixed by the Visual Studio Code team.

Also see:

As a workaround, double-click the PIO home tab.


VSCode 1.40.2 has been released, which includes the necessary fix. No more double click of the tab to regain keyboard focus needed! :slight_smile: