Package framework-stm32cubef4 1.26.2 is outdated

Hi All,

I’m trying to developing some code for STM32F407 that I imported from ST Cube MX. I understood in platform io it used the platform stmst32 and package framework-stm32cubef4 but it seems is outdated. The current most version is 1.26.2 but ST already released 1.27.1 a few months ago. I cannot find anywhere where i can import this new package in platformio registry. It seems like there is a builder in stm32 platfrom that gets the package from ST github repo. I already tried to fixed the version of package to 1.27.1 but I get an error in PIO tool that cannot find the package…

I would like to have some help where to fix or add this new version to registry so I can contribute and update the version of this package.

Thanks a lot!

Because this package version doesn’t exist in the registry: PlatformIO Registry

See STM HAL drivers are out of date · Issue #439 · platformio/platform-ststm32 · GitHub

1 Like

Yes indeed. I tried to uploaded but it seems like that I have to wait for platformio team to upload the new version. Meanwhile I open a new issue requesting it as suggested by @ivankravets

I also tried to override the platform with a prepared package in my github:

platform_packages =
  framework-stm32cubef4 @

The package seems to compile fine! I will try later some project generated by STM32 CubeMX.