OpenOCD init failing no matter what i try

Dunno if the picture works (first time posting here)

So… Ive tried so many things at this point. Both the Arduino and the STM32 framework refuse to upload to any STM32 board i have. Ive tried running PIO through vscode on windows, currently running PIO-core on Arch but still no luck. I can ofc upload to an arduino through PIO but my nucleo and my bluepill dont want anything to do with it and i get this error message no matter what i try. Ive both tried an STLink and just using a USB cable neither of which worked. Made sure to run all the CLI stuff as sudo so its not a permissions thing. I’m stumped.

  1. Make sure udev rules are installed.
  2. Make your the ST-Link’s firmware (on the Nucleo board!) is up-to-date, using the ST upgrade software.
  3. If resetting the chip is the onlky problem you might want to try this: Hold down the reset button of the Nucleo board. Click “upload” in PlatformIO. Wait until OpenOCD starts up. Release it just before OpenOCD tries to access the board. Timing might be tricky.

If that does not resolve the issue, please try uploading with