Nucleo_f302r8 and MBED RTOS

I started a project a month ago and set up the conditional compiles to reflect with rtos and without. Active development was without until today. Now when I compile with PIO_FRAMEWORK_MBED_RTOS_PRESENT, I get missing header files (like “cmsis_os2.h: No such file or directory”) and “Warning! This board doesn’t support Mbed OS!” in the compile output.

Is RTOS really not supported on this build or is it a build error. It was working a month ago.

Current version of mbed = 5.51001.181029

You can switch to the previous version of mbed framework. See Releases · platformio/platform-ststm32 · GitHub

platform = ststm32@4.4.0

@valeros Is the RTOS support dropped by mbed team for this board?

Since the latest release of the mbed framework we provide the OS configuration flag only for boards which officially support that feature (marked as mbed OS 5 enabled),

Your workaround worked.

I went up on and created a generic blinky project for this board. I compiled it and was ok. I then added the rtos.h include and it bitched that it could not find it. I then changed the target to DISCO-L475VG-IOT1A and it gave me the same error.

I could see them dropping support for the 302, but not the 475. I’m not sure what is going on.

And like the idiot that I am, that MBED.COM project worked quite fine when I actually added the rtos library…lol