Nrf52832 cannot use jlink for normal debugging

Hello everyone.
Today I use jlink to debug my nrf52832, platformio can enter the debugging page, but the program will stop at this place.
Click the debug button to start the debug cursor is always this line

1 2

If it is not debugged, the program can run normally in nrf5283.
Is it Platformio’s problem, or I don’t know enough about freertos debugging

I think I may not understand freertos, I am looking for a solution, if anyone can help me, I will be very grateful to him

We encountered the same problem, he is 52840 SOC, I am 52832 SOC

I did not find a solution on the github page of this issue

A comment in that Github issue says there is a workaround that you can restart the debug and then it works?

The problem was solved after restarting the debugging. I also saw this method, but I didn’t believe it would solve the problem :rofl:
What is the reason for this problem? If other users also have this problem, they may feel helpless.

My problem is solved, thank you very much for your answer :grinning:

My best guess is that it has something to do with the bootloader restarting the firmware or doing some USB re-initialization… no further idea though and impossible for me to debug since I don’t have that chip a JLink :confused:

The same type of problem also appears with a SAMD21G18 and SAMD51 series with a JLink.

You will definitely solve this problem. platformio is the best IDE :+1: