PlatformIO Community

Not able to use Terminal to Build, Serial etc

Hello everyone!
Just installed PlatformIO and successfully verified and uploaded code to my WEMOS D1 ESP8266, also Serial Monitor. But now when i have modified the code and tries to upload again i seems like the Terminal window wont open, I cant run commands like Bulid, Upload, Serial Monitor etc.

One window pops-up “Select task to run” and I have no options to choose from.
Strange that this worked the first time, I have tried rebooting the computer and reinstall PlatformIO, no difference.

I am new to VScode so this can be an really easy fix, I don’t know where to start searching for an solution.

Thanks!

What happens when you click the PIO alien icon in the left sidebar? Is there no “Upload” project task available or does it not work?

Same thing, this message is shown:

What VSCode version are you running? Also what’s the list of installed plugins and their versions?

Is your problem maybe related to PIO, VSC can't build, no tasks found?

1 Like

Thank you!!
I read thru the thread and this solved my issue:

Im currently running VSCode:

Version: 1.41.1 (user setup)
Commit: 26076a4de974ead31f97692a0d32f90d735645c0
Date: 2019-12-18T14:58:56.166Z
Electron: 6.1.5
Chrome: 76.0.3809.146
Node.js: 12.4.0
V8: 7.6.303.31-electron.0
OS: Windows_NT x64 10.0.18362

1 Like